I think I broke my Marantz AVR remote control function

Guppe

Member
Hey guys, I this could be a tough nut to crack, but I'm mainly wondering if anyone's ever experienced anything similar.

I've got a Marantz SR6010 and it's no longer doing anything when commanded by its IR remote. It doesn't respond to its own remote and it doesn't respond to an old Harmony remote I've used for years.

Both remotes work. They send out IR, the Harmony controls other devices, I can see the IR LED with a camera and I've even measured the FRONT_IRIN pin on the SR6010's front panel PCB showing a signal when I press a button on the remote. So it's not a problem with the IR part of the RC signal path.

I've had the AVR connected to a CD5004 CD-player via both analog stereo cables and the digital coax, Since I've used one side of a stereo RCA cable to connect the SPDIF line, I've used the other part to connect the remote OUT jack of the AVR to the remote IN jack of the CD-player, because why not, right? Everything seemed to work and the CD-player responded to commands with the remote toggle set to EXT on the CD-player. At least I seem to recall it did.

I sometimes notice that I get nice little shocks when swapping HDMI-cables, because there seems to be a nice 140VAC potential difference between some HDMI sheaths and the chassis of the AVR due to some PSU capacitors somewhere. Obviously no current there, so it's just a little tingle and it hasn't caused any actual problems, unless...

The CD-player has been skipping some tracks recently, so I took it apart to do some cleanup and it seems to work better now. One obscure possibility could be that when I unplugged and/or re-connected the CD-player, if I (dis)connected the remote IN/OUT connection in an unfortunate order wrt the audio jacks and/or the AC plug, perhaps the remote control IN/OUT circuitry took a jolt in the process from the higher voltages and failed. I don't know if this even makes sense, but it's failed recently and the CD player thing was the last thing I did with the setup. It could also be entirely unrelated, because I don't remember using the remote control over a period of two or three weeks before doing the CD-player fix.

Currently, if the AVR is connected via the Remote IN/OUT cable to the CD-player, the CD-player doesn't respond to IR commands either, regardless of which port I use in either device. I even tried to control the AVR via the CD-player by connecting the CD-player's Remote OUT to the AVR's IN, but nothing happens and the CD-player doesn't respond to commands either. The CD-player does respond if I completely unplug the Remote cable, but the same doesn't work for the AVR. I've flipped the INT/EXT switch on the CD-player appropriately for the above scenarios.
Just to be clear, the AVR doesn't respond even if the remote control cable is unplugged.

Just to list some other things I've checked:
- Yes, the Harmony still controls my projector just fine, and the CD-player when the Remote IN/OUT are disconnected.
- The RC lock of the front panel is OFF (hold M-DAX and DIMMER when pressing power button on front panel). I tried playing with this setting when trying the above-described remote-through-CD-player trick, but no joy.
- Everything has been unplugged for a while to "reset" things.
- Yeeees, I've checked the batteries.

I have NOT yet factory reset the SR6010, but I also haven't found any configuration option relating to the remote control in the menus or the manual, so I'm not too optimistic about that helping.

The AVR works fine otherwise. Inputs work, Audio/Video works, web interface works.

I guess I'm trying to ask: Has anyone ever experienced this kind of RC failure before? How did you fix it? Which board is broken? Where could I find a service manual? Are there spare parts available?
I just know that taking this to service is going to cost enough to make it not worth it.
 
Last edited:

Guppe

Member
When I measure the voltages on the remote IN/OUT jacks, the CD-player gives 0V until I press a button on the remote control, and then there's a pulse train on the jack.
The AVR shows a constant 5.20 (standby) or 5.15 (on) volts on the RC IN/OUT jacks that isn't affected by IR signals or the RC lock function. Something's certainly out of order there.

EDIT: Just as an update, in case somebody cares: I sent the whole thing to service. Let's see if they manage to fix it.
 
Last edited:

The latest video from AVForums

Podcast: Sony A90J Thoughts, madVR Processor & Sonus faber Lumina II Reviews + Movie & TV roundup
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom