I think HDMI port is busted

Principino

Standard Member
Maybe 2 months ago my PS3 stopped working with the HDMI, here's the story:

I took my PS3 downstairs to watch a movie and hooked it up with the HDMI cable, all was fine. Next day I realise that it has gone back to normal settings so I try to change it back to HDMI but it just stays on a black screen. I took it back upstairs and the same thing happened with my TV. I bought a new HDMI cable but that didn't fix it and it can't be the cable because it works with my laptop. I tried the holding down the button for 2 beeps method which never worked, I've also reset the PS3 and still no success, it just gives me a black screen with a 'no signal' sign on it. Now I don't think its the TV since it doesn't work on 2 TVs and it's for sure not the cable which leads me to think it's the actual port. I was just wondering if there is a way I can fix this myself, if not I'll have to get it repaired, I called Sony and they said it would cost £110 or something crazy which is a **** take since I forked out £400 for my first one which got the yellow light and £230 or so on my new slim one which is the one I'm having problems with. I went to a game shop and they said try totalconsolerepairs.co.u or somethign along those lines, my exams are finishing this week and I really wanna get this fixed. Has anyone tried that site?? Is it reliable? Or should I just get it fixed with Sony if I can't fix it myself?

EDIT: The PS3 still works with the AV cables but that sucks.

Any help would be appreciated.
 

anorax25

Active Member
Have you possibly got it set at a resolution which the downstairs TV doesn't like? Try going into settings via av cables and start off setting the HDMI port to 720p and work up.

See here : -https://support.us.playstation.com/app/answers/detail/a_id/262/~/ps3-hdmi-picture-problems

This is often a symptom when using an HDMI splitter/switcher connected to two TVs one of which is HD Ready and another which is full 1080p. The PS3 has to be set at the lowest common resolution.

Col.
 
Last edited:

Principino

Standard Member
Well it's currently set at 576i, how would I change this to a higher resolution? I choose HDMI through video output settings but it doesn't give me the option to change the resolution, it just says 'change' which I click and the screen goes black for 30 seconds, obviously I change the TV to the HD output to see if it's changed but I just get the 'no signal' sign.
 

Principino

Standard Member

anorax25

Active Member
Have you tried a different HDMI on the TV?

Both displays are clearly 1080p so that shouldn't be the problem.

Have you tried turning OFF the BD ( blu-ray disk ) setting? Seems possible that this is an HDCP ( High Definition Communication Protocol ) handshaking issue. It's fairly common with lots of devices. It's worth checking the simplest things first before sending anything off for an expensive repair.

Have you tried turning the TV off at the wall as well as the PS3 and waiting 10 minutes? Power up the TV first then the PS3 and try again.
Col.
 

Principino

Standard Member
Yeah I've tried turning it all of for 10 minutes as well as trying a different HDMI. I haven't tried turning off the blu ray disk though, how would I go about doing that?
 

anorax25

Active Member
I'm sorry to have confused you about the BD settings. Here is a screen shot.

Go to Settings/Video Settings and scroll down to the menu item shown and check it's set to Automatic.



Col.
 

Principino

Standard Member
Sorry for the late reply, had an exam yesterday. Really appreciate your help.

So I've just checked and it is set to automatic.

What's weird is that sometimes when I start up the PS3 it tell me that its detected a HDMI cable but when I ask it to change it gives me a black screen again. So that would suggest its not the port. I'm really confused.
 

anorax25

Active Member
You've tried this I assume?


It may also be worth resetting the TV to see if that works. There should be an option to 'Reset to factory defaults'.

Col.
 

Principino

Standard Member
Yep tried that, also tried factory resetting the TV and no success.

Took the PS3 back downstairs to have another go, I'm getting the 'you have a hdmi connected, do you wish to change' which indicates to me that the port is fine, but I click yes and nothing but a black screen.

I did some research as well and a lot of people had success in switching off the TV and taking the plug out for a few mins but that never worked for me.

I'm willing to pay for it to be fixed (obviously not for £110) but I don't want to pay if I can fix it myself.
 

The latest video from AVForums

Star Wars Andor, Woman King, more Star Trek 4K, Rings of Power & the latest TV, movies & 4K releases
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom