• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

Answered I lose dts and Dolby Digital Sound when connecting Projector to PS4 and Receiver

vinz420

Active Member
Hi all,

My problem is that my PS4 doesn't seem to output the designated sound as soon as the projector is connected (or turned on) to my AV receiver. Literally. The sound always comes out as stereo (under LPCM) regardless of the Audio Settings in PS4 settings (Settings > Sound and Display) until I turned off the Projector (to restart it) and noticed that as soon as it shuts off, the AV receiver displayed Dolby 5.1!

I've tried resetting the AV receiver to factory settings to no avail. I've also reset my projector and did nothing. I am now thinking of reseting my PS4 but worried of losing my saved games etc so will do that as a last resort. I need to fix this problem because it's such a waste playing Star Wars with my kids on Stereo :(

This problem is unique because I have my media player, Apple TV and other players working 100% fine on both the AV receiver and the projector so I don't think it's a projector-specific problem. If anything, it's a communication issue between the PS4, the projector and the AV receiver together.

Has someone here had an identical issue before? Has anyone here fixed that problem?

My current setup is: Optoma HD20 Projector, Sony STR-1030 DN AV Receiver, PS4 - all via HDMI 4.1 cables.
 

vinz420

Active Member
Update:

I've just reset the PS4 (Settings > Initialization > Restore Default Settings) to no avail. My next step is to check into the AV Receiver settings now. Wish me luck.
 

vinz420

Active Member
More progress - I SOLVED MY PROBLEM! I'm posting it here to help some other guys that have a similar problem too. As I thought, it was a problem within the AV Receiver. It was forcing the sound to go through both the Amp and the Display at the same time so it would always come out in stereo regardless. So what I did is went through the settings and found the Audio Out under "HDMI > Audio Out " then select "AMP" (it was AMP+TV before).

Hope this would help other guys.
 

The latest video from AVForums

Guardians of the Galaxy Xmas Special, Strange World, Bones and All, and Cabinet of Dr Caligari in 4K
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom