I have problem in Denon 1908

Discussion in 'AV Receivers & Amplifiers' started by jvbint, Jun 16, 2009.

Tags:
  1. jvbint

    jvbint
    Standard Member

    Joined:
    Mar 12, 2009
    Messages:
    9
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Hi,
    i have denon 1908 av reciever. Most of time i use this with generator because of power problem. I have been facing a problem that whenever i connect my pioneer dvd with amp thru hdmi and amp to lcd again hdmi, it sounds some sparking noise from speaker, like some electric spark or something and later amp come to safe mode. But when i attach dvd direct to tv with hdmi and coaxil to amp, it works properly. I have informed denon people also but they are also confused about this. They say that it may because of generator power supply. If it is that then why it work well with coaxial.
    Any body can help me in this ?
     
  2. Cable Monkey

    Cable Monkey
    Well-known Member

    Joined:
    Feb 10, 2002
    Messages:
    3,494
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    106
    Location:
    Birmingham
    Ratings:
    +205
    You must use power conditioning with a generator. They are at best for emergency use only and if you want to protect your gear you should use a conditioner.
     
  3. jvbint

    jvbint
    Standard Member

    Joined:
    Mar 12, 2009
    Messages:
    9
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Thanks for this. I will install a power conditioner then check.
     

Share This Page

Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice