I am legend only showing dolby digital when i press select


Prominent Member
As the title really. Just watched I am Legend. When i press the select button it only shows the sound as dolby digital. I thought it would be Dolby HD. Still sounded very good though. I have the sound setup as linear pcm through HDMI to my onkyo 605. Couldn't find amy in film menus to change sound settings. Anyone help?


Established Member
If you have the Blu-Ray remote, just press the Sound button until you see Dolby TrueHD, if not, then open the on-screen menu by pressing the triangle, go to Sound and select it there.


Prominent Member
Bugger, went in there to try and change the audio. Never noticed the second english option was HD. Oh well have to watch it again with the alternate ending. Gutted. Thanks for the help though. :thumbsup:

It still sounded good in normal dolby though. lol.

The latest video from AVForums

Tribit StormBox Blast Bluetooth Speaker: Review Coming Soon
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom