• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

Humax PVR 9300T problems

spot0806

Established Member
Hi Guys,
Ive just got one of these units and I'm having a few problems with the record function. When i press the red button on the remote control nothing happens? I have had it recording but it will not let me watch any other channel when i am recording, the screen just stays black with no sound either. This is my first PVR i have the aerial in the correct place and the TV is connected using the HDMI cable. Watching programs is ok just the record function up to now has gone wrong.
Help!!!!lol
 

nvingo

Distinguished Member
It is not the red, of the four fastext/menu buttons but the "record" button with a red circle that you are pressing for instant record ?

Try the PIP (picture in picture) to determine you can receive any two channels simultaneously. If not, do a Defaults Setting and retune, then try again.

To set schedules from the EPG, highlight the desired programme and press the "OK" button, not record.

If you cannot, under any circumstance, receive two channels and the signal level/quality displayed during manual tuning are 50%+/100%, return to retailer as faulty. Rare but not unheard of.

EDIT: if possible try with the HDMI removed and a scart used instead. Slight possibility of HDMI signal interfering with Freeview reception.
 
Last edited:

spot0806

Established Member
It is not the red, of the four fastext/menu buttons but the "record" button with a red circle that you are pressing for instant record ?

Yeah matey i knew i had the record button

Try the PIP (picture in picture) to determine you can receive any two channels simultaneously. If not, do a Defaults Setting and retune, then try again.
Tried that and i didn't have the PIP, then did the retune and bingo all is ok very happy

To set schedules from the EPG, highlight the desired programme and press the "OK" button, not record.

If you cannot, under any circumstance, receive two channels and the signal level/quality displayed during manual tuning are 50%+/100%, return to retailer as faulty. Rare but not unheard of.

EDIT: if possible try with the HDMI removed and a scart used instead. Slight possibility of HDMI signal interfering with Freeview reception
Many thanks for your help matey:thumbsup:
 

The latest video from AVForums

Spielberg, Shyamalan, Aronofsky, Chazelle, Eddie Murphy and Mel Gibson - all the latest movies
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom