Humax PVR-8000T firmware upgrade problem (via PC)

Discussion in 'Digital TV & Video Players & Recorders' started by dillspooch, Sep 20, 2004.

Tags:
  1. dillspooch

    dillspooch
    Active Member

    Joined:
    Jan 1, 2004
    Messages:
    71
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    11
    Ratings:
    +4
    I wanted to get the upgrade for my Mum's PVR-8000T but we missed the recent auto-update.

    I have the correct cables for performing the upgrade but couldn't get it to work. I followed the instructions on the Humax site but the PVR did not detect the firmware update taking place over the cable from my laptop. I tried various baud rate settings none of which had any effect.

    Should I set the parity, data bits, stop bits, and flow control to any specific settings to make this work?

    The cables I have are a male serial to 3 pin din (direct from Humax) and a serial null modem cable (pins 1-7,2-3,3-2,4-6+8,5-5,6+8-4,7-1) bought from Netshop.

    I tried switching on from Standyby and a power off/on cycle whilst running the WDN40AK software.

    Any suggestions before I contact Humax support?
    Thanks
    Mike
     
  2. Davycee

    Davycee
    Standard Member

    Joined:
    Sep 20, 2004
    Messages:
    3
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    3
    Ratings:
    +1
    Mike,
    I did it following instructions shown on www.radioandtelly.co.uk/freview_humax.html. If you look down that web page, you'll see a kind of FAQ which includes one saying 'How can I manually update my software'. This is what I did.

    a. connect my null modem cable to the Com 1 port on the PC & the rear RS232 of the Humax.

    b. In Windows XP Control Panel>System>Hardware>Device Manager, select Ports. Just to be sure, I altered the baud settings to 115200 for both COM1 & COM2. [For info, the other settings are: Data Bits = 8; Parity = None; Stop Bits = 1; Flow Control = None.

    c. Turn OFF the HUMAX using the main power switch on the rear upper right.

    d. Double click the WDN40AK icon. Whn it loads its little window, click on the file folder icon & then point it to the .hsf file (wherever you saved it to). Once it's found it, you'll go back to the main window & a 'Download' button appears. The window also shows your baud setting as 115200 I hope. Once you click 'download', the little window shows a message saying it's trying to connect to the Humax (but failing). Now switch on the power switch on the HUMAX and the download starts automatically. You'll see the transfer numbers counting up on the PC & the Humax display will catch up at intervals.

    e. Keep watching. Once the download has finished from the PC, the Humax display will change as it goes through whatever internal processes it needs to. DO NOTHING UNTIL THE DISPLAY SHOWS 'END'.

    f. Remove the mini-DIN from the back of the Humax & switch the power OFF then ON. Once it's restored, you'll find you can now record radio etc.

    Sorry this is so long, but it's just worked for me.
    Best of luck,
    David
     
  3. dillspooch

    dillspooch
    Active Member

    Joined:
    Jan 1, 2004
    Messages:
    71
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    11
    Ratings:
    +4
    Thanks Davyee. I re-checked my settings and those are the ones I've used, and the procedure I followed.
    Hmm. methinks I might have the wrong cable.
     
  4. Ikki

    Ikki
    Member

    Joined:
    Feb 23, 2004
    Messages:
    1,173
    Products Owned:
    2
    Products Wanted:
    0
    Trophy Points:
    67
    Location:
    Lancs
    Ratings:
    +97
    Make sure that the cable is a 'null modem' cable. It is essential that the Tx (transmit) and Rx (receive) lines cross over between each end and do not go from pin to pin or no data transmission will take place. Here is a wiring diagram of the cable (n.b. other pins may be connected but can be ignored).
     

    Attached Files:

Share This Page

Loading...