Humax Foxsat HDR - continually scrolling through channels - now dead - help!

EMcG

Novice Member
When I powered up the FoxSat this morning it acted very oddly.

Firstly, it was continually scrolling through the channels on it's own with nobody touching the remote. I managed to get the menu option open but it was just scrolling through that too.

I switched off the box at the power switch. Let it have rest. But now it won't power back on - the blue light comes on for a moment then goes back to red.

Any ideas?

Thanks
 

EMcG

Novice Member
Update

Now getting the Humax screen with the words 'Updating...' and 'Press Stand By Button to Restart'. But this has no effect when done.
 

logiciel

Moderator
Time to get it back to the supplier?
 

logiciel

Moderator

EMcG

Novice Member
May have spoken too soon. Just been watching 'Frozen Planet' and on two occasions the recording has fast fowarded completely on it's own. Is this a known issue? Thinking of doing a factory reset.
 

Railway

Active Member
May have spoken too soon. Just been watching 'Frozen Planet' and on two occasions the recording has fast fowarded completely on it's own. Is this a known issue? Thinking of doing a factory reset.
Maybe if you continue having problems try connecting the drive to a PC (if you can) and running the Seagate disk test utility Seatools, this will check the drive for errors and not harm the data, you can run it from a bootable disk so don't even need windows.
Good luck. :smashin:

Read the instructions as some tests are destructive !!
 
Last edited:

EMcG

Novice Member
It's gone and done the same thing again and this time the software reload didn't work. Sent an email to Humax direct to see about getting it fixed. Does anyone have experience of their services?
 
Last edited:

logiciel

Moderator

grahamlthompson

Distinguished Member

caldirun

Member
May have spoken too soon. Just been watching 'Frozen Planet' and on two occasions the recording has fast fowarded completely on it's own. Is this a known issue? Thinking of doing a factory reset.
When you get it working again try covering the remote IR window on the Foxsat except when you want to use the remote, could be another device causing the problem!
Just seen the other post, you dont have a remote controlled helicopter do you?
 
Last edited:

logiciel

Moderator

The latest video from AVForums

Podcast: Reported HDMI 2.1 bugs, Audiolab Amp & LG LED Projector reviews + Best of the Month
Top Bottom