Humax box has short circuited my aerial

Discussion in 'Freeview & YouView' started by Kendra kuche, Jul 30, 2012.

  1. Kendra kuche

    Kendra kuche
    Novice Member

    Joined:
    Jul 30, 2012
    Messages:
    1
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Hi, I wonder if anyone can help. Just moved into a new flat, it has a Samsung tv with built in freeview that worked perfectly, all the channels, perfect signal etc. today I tried to plug in my humax freeview recorder that worked fine in my old house). I unplugged the aerial cable from the tv and plugged it into the humax. When I turned it on it briefly said 'aerial short circuited', then it failed to find any channels. I checked everything. Finally I plugged the aerial cord back into the tv but now the tv says 'no signal' and can find no channels either. Is it possible the humax box broke the aerial? And if so, how can I fix it? Thanks!!!
     
  2. Gaspode_TWD

    Gaspode_TWD
    Active Member

    Joined:
    Jun 3, 2008
    Messages:
    720
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    31
    Location:
    Thame
    Ratings:
    +69
    The aerial will not, normally, have any power in it, so it is unlikely to have done permenant damage. It sounds as though the act of pulling out and pushing in the lead has broken some part of it. Do you have any other leads you can try (you usually get a free one with each component you buy)? If not try taking the aerial plug apart and re-making it making sure you avoid any shorts.
     
  3. Railway

    Railway
    Active Member

    Joined:
    Nov 29, 2009
    Messages:
    721
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    43
    Ratings:
    +105
    Sounds like the Humax is set to provide power to an aerial amplifier / distribution amp, presumeably if you have one it is already powered?
    You need to disable the Humax from supplying aerial power at your new property.

    The fact you get no channels on your TV could mean damage has been done to the amplifier / distribution amp (if there is one) at your new property but don't panic could be other things.

    Go through the menus on the Humax and disable antenna power as a start.

    Of course maybe you do have a short in the cabling.
     
    Last edited: Jul 30, 2012

Share This Page

Loading...