Humax 9200T, eLinker, Initialization of receiver failed!! Help


Standard Member
I was uploading some files from my humax 9200T using media elinker, which had been working fine. I had left it to finish off and when I returned the connection had been lost and everytime I try to connect it says "initialization of receiver failed! Restart receiver". Well, I tried that and even tried reinstalling it but it still won't connect. Please, any help would be appreciated.

Paul Shirley

Active Member
Disconnect then reconnect the USB cable or take the 9200 to standby and back or disable then reenable the Humax STB device in device manager.

The USB drivers on the 9200 stink of rotting fish...

Tinderbox (UK)

Active Member

I have given up trying to download from my 9200t, I have tried it on several computers with all versions of elinker and the alternative one, and 4 or 5 different cables, also setting priority to realtime, no good.

I get a connection, and the file starts to download, but it always stops with an error.

I have not managed to download even 1 file.

I bought a graded version, I wonder if mine is faulty.



Paul Shirley

Active Member
There's always the cable mod to try rather than wasting more time on eLinker...

Another alternative is bypassing the 9200, less than £30 will get you dual tuners for direct recording to your PC. I've almost completely given up using my 9200, the PC is more reliable, happily running 4 tuners and doing things the 9200 can't - like correctly padding back to back recordings. The 9200 is of course still crashing every week or so without my help but my wife knows how to reset it by herself :devil:

The latest video from AVForums

Podcast: Panasonic JZ2000 Final Thoughts - TV Calibration: Should you? And More...
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom