• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

HTX-22HD No signal What am I doing wrong?

blaster9999

Established Member
I have kept away from amps, for a very (very) long time. Just set up the basic 2.1 system at this time, feeds from one sony bdp350 via hdmi. Then out to the tv via one hdmi.
no pcture , no sound .
Deff a feed from the player and I've tested the two hdmi cables involved.
I've set the room up with the supplied mic. test sound seems to be coming out ok. but still no feed

What have I overlooked:suicide:

edit: a little playing around and i've got a signal through by switching the input to cable/sat.
I've been able to switch that to either input and get a feed. With it set to dvd on either hdmi just a blank screen and no sound?
 
Last edited:

blaster9999

Established Member
Never did work what went wrong. Found someone who had this already he couldn't figure out what I'd done so ended up does a factory reset now works fine, just have to go through room calibration again.

Overall this this is a good budget set, manual could be better signif step up over my tv speakers. Just wish had the room to turn it into a full 5.1
 

The latest video from AVForums

SVS Prime Wireless Pro Powered Speakers - Review Coming Soon
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom