HTC One on Three: Wifi and Bluetooth tethering disables internet?

wellsi

Active Member
Just tried to tether my tablet to my new HTC One M8; tried by both wifi and bluetooth; both connect without issue, but internet doesn't work.
I bought the handset outright as a Three PAYG handset, and put in my existing contract SIM.

My plan doesn't let me tether, but I've always been able to tether to my tablet, but not a laptop (if I tried the lap top, I got the "it looks like you're tethering which is not allowed on your plan"). So I figured I'd still be abel to tether my tablet as I've always done with my previous phone (Samsung G S3). No joy.
Is it safe to assume that the Three stock phone has this function secretly disabled, without actualy telling you? Or do I have a setting wrong? Phone and tablet both say that 'internet is being shared' but I can't connect to any web site.....
Can others tether to a tablet on Three?

Cheers
Ian
 

wellsi

Active Member
Ah well.... the auto-text from Three has confirmed that 'tethering is not allowed'. This is really annoying as it's always worked on a tablet and worked fine via my last handset (same contract); so is the the HTC M8 offering new levels of detection for them so they can now block tablets as well?.... :(
 

jerryq7777

Well-known Member
Maybe try an app for tethering might work.
 

Some Bloke

Well-known Member
I can tether my (SIM free) m7 to a tablet.
I start a HotSpot, then on the tablet switch on WiFi and select the HotSpot connection.
Entering the username and password and connect to the internet via the phone's cellular connection.

Both devices are rooted and I'm using this firewall Android Firewall - Android Apps on Google Play
There is a check box, that needs to be ticked to allow tethering in the firewall.
Otherwise it won't work. And I just see that the devices are connected and can't do anything else.
Maybe check you security, to see if anything is being blocked.

If you still can't get it to work and your devices are rooted and you've got a Nandroid backup for both. I'd factory reset both and try tethering again.
Then once you know what the problem is, restore the backups and make adjustment to make it work.


Good luck.
 

The latest video from AVForums

Star Wars Andor, Woman King, more Star Trek 4K, Rings of Power & the latest TV, movies & 4K releases
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom