HTC desire z - signal issues

milavzla

Standard Member
Hello,

After a long wait I finally received my desire z last week. Being my first htc I was very excited about it, and it's everything I expected it to be...except as a phone to receive calls. I've encountered this problem, when the mobile goes into power save (1-3 mins depending on settings) it immediately loses phone signal (i have an o2 simcard) so I can't receive any texts or calls! I'm only get them if they come in while I'm using the phone. Otherwise they go to voicemail.

I've looked and looked online and no one else seems to be having this problem (or talked about it). I don't think it's the sim card since I tried it on my old phone and it works as normal. I've requested a new sim card just in case and it should arrive this week.

Any ideas why this is? I'm afraid it's a manufacturing problem and I only hope it's not for all Desire Zs. Any suggestions on settings I should change? This has happened from day 1 and I even rebooted it to factory settings and still have the same problem.

Thanks in advance for the help!
 

manavkataria

Standard Member
I am facing similar issues on my HTC Desire Z -- Low network / signal at office which used to receive full signals on my earlier nokia phone.

Would like to know how you sorted out the issues. Settings change / new sim card? whatever worked.

Thanks!
 

weirdbeardmt

Standard Member
I have a similar issue whereby the phone inexplicably loses signal and never gets it back, I can search for new networks etc, finds all the other ones, except mine. But if I just restart the phone... everything works as normal. It's infuriating because I can go a few hours and not realise that it has lost signal.
 

manavkataria

Standard Member
Try the following. It worked for dad's phone, which had these issues earlier.

Goto:
Settings > Wireless & Networks > Mobile Networks > Network Mode
Set Network Mode to -> 'GSM Only'
 

weirdbeardmt

Standard Member
Try the following. It worked for dad's phone, which had these issues earlier.

Goto:
Settings > Wireless & Networks > Mobile Networks > Network Mode
Set Network Mode to -> 'GSM Only'

But then you only get a GSM/Edge connection not 3G - which was the whole reason I bought the phone!
 

weirdbeardmt

Standard Member
I contacted HTC support about it. They responded very promptly so kudos for that, but their suggestion? Do a factory reset and put it back to standard settings... i.e., lose all the customisation, tasks etc. that I've done. Hmm...
 

The latest video from AVForums

Podcast: Q Acoustics Q3030i, Humax Aura, Roku Streambar & WandaVision Reviews and more...
Top Bottom