1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

hs20 and dust!

Discussion in 'Projectors, Screens & Video Processors' started by bigsteve, Apr 8, 2004.

  1. bigsteve

    bigsteve
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    I have just received my Sony HS20, after deliberating for several months. To my horror, as soon as the projector was powered up, I noticed a bright green blob on the bottom right hand side of the screen, indicating dust!

    It is possible to focus on this, and it clearly shows a tiny hair like piece of dust. Does this indicate that the dust is on an LCD panel, or somewhere within the optics?

    Is there anything I can do to remove it, as there are no dead pixels and colour uniformity is fantastic, or should I return it to the company I purchased it from?

    Thanks for any advice.

    Steve.
     
  2. clancol

    clancol
    Active Member

    Joined:
    Sep 6, 2003
    Messages:
    1,023
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    38
    Location:
    Middlesbrough
    Ratings:
    +7
    YES YES YES.
    All the way back.
    You don't want to go searching for dust blobs on a brand new projecter.
     
  3. Kramer

    Kramer
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Probably a little debris left from the manufacturing/assembly process.

    Brand new PJ - yes, return it I'd say.

    :smoke:
     
  4. Joeki

    Joeki
    Standard Member

    Joined:
    Jul 22, 2003
    Messages:
    50
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    6
    Location:
    Starside
    Ratings:
    +0
    Worth having a look in case its just on the plastic lens cover, it just clips off. I had a mark on mine but it came off easily.
     

Share This Page

Loading...