Dismiss Notice
Attention AVForums app / Tapatalk users
Sadly GDPR means that, from 25th, we can no longer offer access to AVForums via the branded app or Tapatalk.
Click here for more information.

HS2 problem

Discussion in 'Projectors, Screens & Video Processors' started by DeanHyndman, Jan 26, 2005.

  1. DeanHyndman

    DeanHyndman
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    I have a probelm with Sony HS2 projector, the screen as started to go blue at the bottom, the blue haze moves and changes shape until it looks like ink being absorbed by blotting paper.

    Has any one any ideas?
     
  2. vicbarry

    vicbarry
    Active Member

    Joined:
    Oct 13, 2003
    Messages:
    457
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Location:
    Cork
    Ratings:
    +7
    Sounds possibly like a bit of dust blowing around inside! Give it a clean with some compressed air. Might be time to change the air fileter too!
     
  3. DeanHyndman

    DeanHyndman
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Thanks, but I don't think its dust, have cleaned out best one can. One repair shop said it was LCD panel, another doesnt!

    Who knows, I think I will have to send back to Sony
     
  4. summat

    summat
    Standard Member

    Joined:
    Dec 16, 2004
    Messages:
    90
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    6
    Location:
    Preston
    Ratings:
    +0
    :eek: Sounds very much like a failing LCD panel; I think you're right re. back to Sony :eek:
     

Share This Page

Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice