HS10 repairs,... this may help others

malcolm

Novice Member
HI guys,
Well it's another HS10 revisiting its maker! Off to heathrow tomorrow for repairs. Its suffering from both the lamp bugs. So when it eventually starts it turns itself off. :rolleyes:

The problem i may encounter is with the warranty. The machine was bought from nexnix in august, but was a demo unit.

They only want to see the receipt as proof of purchase, but it will be for much less than a new machine. So i'll see what happens there.

Anyway my joker card is this pdf orginally posted by Markatlarks, it clearly states in my mind that there is manufacturing problem with the Lamp cover and they advise replacing it with a improved part.

http://62.6.248.8/Indexes/pi/EB/Jun_2003/00032331.pdf

If it is a manufacturing fault shouldn't all HS10's be fitted with the new part free of charge? If it were a car for example it would be fixed regardless of warrenty. I'm not sure where the comsumer stands on this matter but i hope its in my favour.

I'll update this thread when more has transpired.

Mal
 

common

Active Member
yours can say hello to mine which is in Heathrow waiting to be seen for the same reasons !!

I'm sure you will be OK with the warranty
 

malcolm

Novice Member
I'm almost scared to ask but how long has yours been there?
And how are you coping with out it?
I don't think i'll know what to do with myself :confused:
 

common

Active Member
went last Friday, when I called yesterday to confirm they had received it they mentioned it was in a queue waiting to be seen, I should find out more next week.

I'm thinking about 2-3 weeks - nightmare without it, really miss that 8ft xbox gaming experience
 

Respectamonkeee

Standard Member
Mine was gone 5 weeks and when i phoned after 4 it was still waiting unopened to be looked at......add 2 weeks to what ever they tell you!!

They changed my bulb and a lamp door assembly and its been cracking since....has made me change my mind on upgrading to DLP for another yr.
 

malcolm

Novice Member
So it looks like i'm in for the long hall!

I must admit it didn't start well today as it wasn't collected as arranged. Very glad i'm having it picked up from work and didn't stay at home for them!

The ceiling is looking very bare tonight and the dangling cables look very unhappy! I think my X-box shed a tear earlier and the HTPC has put itself on e-bay! Oh well, life goes on! :rolleyes:

Thanks for the feed back its comforting to know others are going through this experience as well.
 

malcolm

Novice Member
My PJ has been recieved by Sony and it seem sthey will honour the warrenty! :D

Common have you had yours back yet?

I'm going to call tomorrow to get an estimate of how long it will take!
I wont hold my breath though.
 

common

Active Member
Mine has been seen and new parts ordered - I called them yesterday and they expect to have it back to me by Friday - lets see - I think that's about 3 weeks
 

malcolm

Novice Member
well they've had mine a week now, i called today and its not been seen yet. Will call again next tuesday.

Common i hope you get it back on friday!
Before i go research wheres best to buy a 9m DVI cable, you wouldn't have any suggestions? No rush! :rolleyes:
 

common

Active Member
Took 6 weeks but it's back and looking good - no instances yet of auto switch off or over heating
 

malcolm

Novice Member
3.5 weeks for me! The Bulb is much brighter than the old one which only had 380 hours on it.
Starts first time and doesn't turn itself off! Long live my HS10!
 

lukej

Standard Member
Sorry to hijack this thread but where are you people sending your
hs10 to be fixed? When you say heathrow do you mean the airport or do sony have a repair centre in heathrow?
Do they have a contact number?
Thanks,
lukej
 

The latest video from AVForums

Samsung Micro LED, Mini LED, NEO QLED TVs and More: AVForums Podcast Interview
Subscribe to our YouTube channel

Full fat HDMI teeshirts

Support AVForums with Patreon

Top Bottom