HP Elitebook 840 G3 not seeing battery.


My laptop has stopped seeing the CS03XL battery.

Windows says battery status: 0% available (plugged in)

HP Support Assistant states that it can't find a battery.

I have tried removing the battery and then refitting it and that made no difference so I bought a new battery and that did not work either. Tried a third CS03XL battery and still windows and HP Support does not see the battery.

I have Googled it and tried all things like deleting battery drivers, hard laptop reset/reboot etc, nothing has worked.

Laptop only works now on mains ac power and does not charge the battery no matter what one I put in the laptop. If I pull out the power cable, the laptop turns instantly off as you would expect.

Does anyone have any ideas, really want to be able to get the laptop working on battery again.



Yes. However no matter what charger was being used it would not explain how HP support assistant just stopped even seeing a battery.


Active Member
Well, if your not using a HP Charger the battery won't charge and the chip that is used to detect it won't be activated... I would imagine.

The latest video from AVForums

Maverick UK Premiere IMAX Review + Top Gun, Tom Cruise, Tony Scott and 4K + Movie/TV News
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom