Quantcast

HOWTO: Sky through DVB-S card within MCE *Part 4*

Curly99

Distinguished Member

Last Post
Hi everyone,

just wondering if anyone else has noticed any problems recording from the majority of Sky HD channels recently?

For example Sky1 HD, Living HD, Atlantic HD, FX HD etc.

My recordings for any of these channels recently, record for the hour, but when I try to play them back, just get returned straight back to the previous form.

Anyone else seeing this?

I even had to dig out my Sky HD STB, so thats the second time its ever seen the outside world... These channels work on there, but still not via my Technomate.

Non HD channels are still working fine


Thanks
Tony
 

tony_park

Active Member
Hi John

Unfortunately its just encrypted HD channels

Thx
Tony
 

ChileanLlama

Novice Member
Hi Tony, is it just recordings or LiveTV as well?

It sounds like it may be related to hdd space and/or buffer size within MCE. What size disk(s) do you have and what's your buffer sizes set to?
 

tony_park

Active Member
Hi,

both live and recorded tv - there's no problem with space, its a 2TB drive, with half free.

What do you mean by buffer size? I'm assuming you mean, the allocated space per tuner for recordings? If so, I don't think this will be a problem given the amount of space spare. Last time I checked, we had the buffer set to 2 hours, for paused tv storage. On my system drive, thats a 60Gb SSD drive, with 40 GB free.

Also, checking via the dvblink server, VLC is not able to play the channels, and acamdmonitor shows unable to decode. I'm wondering if its something to do with my setup on the technomate. May try playing with it over the weekend, to see.

Thanks
Tony
 

ChileanLlama

Novice Member
Yes I meant the allocated space. Make sure it's set to your 2TB drive. Not sure how many feeds you have but I have found that if you have 4 HD feeds then a 60GB SSD won't be big enough, certainly not for 2 hrs. So it sounds like it's on the hdd.

What guide are you using, remember the problem I had a bit since (it's in part 3) when I was using EPGCollector and DVBLink server was crashing, which resulted in similar problems after about an hour of play. Though that affected all channels, not just HD, and required a reboot/restart. Basically I had it set so that EPGcollector was collecting on all 4 feeds, instead of just one. Doh!

What happens if you restart the PC, does it playback then?
 

tony_park

Active Member
Hi,

its def set to the 2TB drive :) I have 4 feeds - 2 dual S2 tuners.

I'm using digiguide uploading to MC via big screen epg currently - so it doesn't touch the tuners at all.

Nope, a reboot doesn't change it :-(

Acamd monitor shows:

13:58:24.316: Ch: 259 - AnimalPlnt HD
13:58:24.316: Programm crc: 00608E70
13:58:24.317: PMT: ACamd_PMT.txt, search, not found PMT=0103 (AND SID=0EE5)
13:58:24.317: 0x0103 0x0EE5 0x0963 0x00000000 0x0503 0x00C0 11111110
13:58:24.469: Newcamd 0: ECM [0503][0963/00000000] Pro (0.120)
13:58:24.469: Newcamd 0: ECM [0503][0963/00000000] not able to decode
13:58:27.183: Newcamd 0: ECM [0503][0963/00000000] Pro (0.118)
13:58:27.183: Newcamd 0: ECM [0503][0963/00000000] not able to decode
13:58:35.325: Newcamd 0: ECM [0503][0963/00000000] Pro (0.130)
13:58:35.325: Newcamd 0: ECM [0503][0963/00000000] not able to decode
Thanks
Tony
 
Last edited:

ChileanLlama

Novice Member
Hi Tony, for some reason I haven't got this one mapped - is it a relatively new channel in the last few months?

Anyway, I'm getting the other HD encrypted channels fine. I also set up a system for my neighbour this weekend, we found that the DM500 clone's tuner wasn't as good as mine, we had to boost the signal to get a lot of encrypted channels. Also their card had scorching on the chip (from an Amstrad box) and is very unreliable - sometimes picking up channels, sometimes not, occasional drop outs. It seems to be worse when multiple channels are being un-encrypted.

I doubt it's the signal for you, but I'd hazzard a guess it's either the TM500 or there is a possibility it's your card - not sure if you would have considered this last factor?
 

tony_park

Active Member
Hi,

found the problem now... on the oscam.server file, I had to add my box id, now hd channels are clearing again.

Wonder if Sky have changed their setup slightly, to make HD channels require this setting... but at least its working again.

Yep, we have an Amstrad box, and the card came out a lot warmer, than it does out of my TM500, so I can't see it doing it much good!

Hopefully I can continue to test it tonight, for a good couple of hours ;-)

Thanks
Tony
 

ChileanLlama

Novice Member
That's interesting. Mine reads the boxid from the card, I don't have it in the config files. I did the same on the neighbour's box too and was picking up the HD channels on both set up's.

Will need to watch out for this and add it if necessary.
 

Ruudfood

Active Member
Hi Everyone

The original post in the 1st of these threads is from 2006, so the hardware and software is just a little outdated! :D

Is there a more up-to-date guide with the equipment required and how a relative novice like me could go about setting this up from scratch?

I hope so because I bet not may will be willing to write one! :D

Thanks in advance for your help.
 

BenRyder

Novice Member
That's interesting. Mine reads the boxid from the card, I don't have it in the config files. I did the same on the neighbour's box too and was picking up the HD channels on both set up's.

Will need to watch out for this and add it if necessary.
Yeah. Ditto to this. Mine reads it automatically with Oscam and has been decoding absolutely fine.
 

tony_park

Active Member
I think our build number is quite an old one, being 0.99.4 SVN build 1851.

I'll try updating to a later version manually later and see what happens, however I'll probably just keep the number in place in the end, for safety!
 

ChileanLlama

Novice Member
Hi Everyone

The original post in the 1st of these threads is from 2006, so the hardware and software is just a little outdated! :D

Is there a more up-to-date guide with the equipment required and how a relative novice like me could go about setting this up from scratch?

I hope so because I bet not may will be willing to write one! :D

Thanks in advance for your help.
You should really read part 3 at the very least.

You're then faced with a choice of either an Omnikey USB card reader on your HTPC or a Dreambox clone to handle the card entitlements and pass these back to the PC software handling the satellite feeds.
 

ChileanLlama

Novice Member
I think our build number is quite an old one, being 0.99.4 SVN build 1851.

I'll try updating to a later version manually later and see what happens, however I'll probably just keep the number in place in the end, for safety!
Tony if it helps I'm on 1.00 build 4863. I used a Gemini image with Oscam integrated, and other than the network setup it only needed the Oscam.user file modifying after the flash.

I can share this with you if you want to give it a go, I'm assuming the TM500 uses the same images as the DM500?
 

tony_park

Active Member
Hi,

I think the processor in the tm500 is a powerpc chip, if I remember correctly.

I downloaded a newer version yesterday, just haven't managed to find time to copy it across to try it - since the pc was recording some programs last night. Could do with a nice quiet period where I can test before screwing everything up :facepalm:

I'll let you know how I get on...


Thanks
Tony
 

DragonQ

Novice Member
For some reason my card isn't updating entitlements whilst plugged into the Omnikey 3121 (using OSCAM 1.10 svn6089 Stable and ACAMD 0.6.2.0). I updated them with a Sky+ box tuned to Pick TV +1 for 24 hours when I first got the card, but I did the same with it in the Omnikey last night and nothing. First entitlements expire in three weeks so need to get this sorted! Here's my OSCAM files - am I missing something here?

oscam.conf
Code:
[global]
logfile                       = /dev/tty
disablelog                    = 0
disableuserfile               = 0
usrfileflag                   = 0
clienttimeout                 = 5000
fallbacktimeout               = 2500
clientmaxidle                 = 120
bindwait                      = 120
netprio                       = 0
clientdyndns                  = 0
resolvedelay                  = 30
unlockparental                = 0
nice                          = -1
serialreadertimeout           = 1500
maxlogsize                    = 2048
waitforcards                  = 1
preferlocalcards              = 1
saveinithistory               = 1
readerrestartseconds          = 4
lb_mode                       = 1
lb_save                       = 0
lb_nbest_readers              = 1
lb_nfb_readers                = 1
lb_min_ecmcount               = 5
lb_max_ecmcount               = 500
lb_reopen_seconds             = 900
resolvegethostbyname          = 0

[newcamd]
port                          = [email protected]:000000
key                           = 0102030405060708091011121314
allowed                       =
keepalive                     = 1
mgclient                      = 0

[webif]
httpport                      = 8181
httpuser                      = ADMIN
httppwd                       = ADMIN
httprefresh                   = 0
httpallowed                   = 127.0.0.1,192.168.1.90-192.168.1.110
httphideidleclients           = 0
httpreadonly                  = 0
oscam.server
Code:
[reader]
label                         = cam1
enable                        = 1
protocol                      = pcsc
device                        = 0
services                      =
caid                          = 0963
ident                         =
group                         = 1
emmcache                      = 1,3,2
ecmcache                      = 1
blockemm-g                    = 1
blockemm-unknown              = 1
blockemm-u                    = 0
blockemm-s                    = 0
lb_weight                     = 100
oscam.user
Code:
[account]
user                          = USER1
pwd                           = USER1
disabled                      = 0
expdate                       =
group                         = 1
hostname                      =
uniq                          = 1
sleep                         = 0
monlevel                      = 1
au                            = cam1
services                      =
caid                          = 0963
betatunnel                    =
ident                         =
chid                          =
cccmaxhops                    = 10
keepalive                     = 1
numusers                      = 0
penalty                       = 0

[account]
user                          = USER2
pwd                           = USER2
disabled                      = 0
expdate                       =
group                         = 1
hostname                      =
uniq                          = 1
sleep                         = 0
monlevel                      = 1
au                            = cam1
services                      =
caid                          = 0963
betatunnel                    =
ident                         =
chid                          =
cccmaxhops                    = 10
keepalive                     = 1
numusers                      = 0
penalty                       = 0

[account]
user                          = USER3
pwd                           = USER3
disabled                      = 0
expdate                       =
group                         = 1
hostname                      =
uniq                          = 1
sleep                         = 0
monlevel                      = 1
au                            = cam1
services                      =
caid                          = 0963
betatunnel                    =
ident                         =
chid                          =
cccmaxhops                    = 10
keepalive                     = 1
numusers                      = 0
penalty                       = 0

[account]
user                          = USER4
pwd                           = USER4
disabled                      = 0
expdate                       =
group                         = 1
hostname                      =
uniq                          = 1
sleep                         = 0
monlevel                      = 1
au                            = cam1
services                      =
caid                          = 0963
betatunnel                    =
ident                         =
chid                          =
cccmaxhops                    = 10
keepalive                     = 1
numusers                      = 0
penalty                       = 0
In my C:\Program Files (x86)\Team MediaPortal\MediaPortal TV Server\MDPlugins\7231 BDA Digital Capture DVBS0\cardclient.conf file I have:

Code:
newcamd:127.0.0.1:15008:1:USER1:USER1:0102030405060708091011121314
Today it's been tuned to Pick TV +1 for a few hours and the OSCAM web interface shows absolutely no EMMs received at all (none blocked, none skipped, none written, none error). From looking at other posts on other forums, something should've happened as some providers send global EMMs every minute! :(
 

tony_park

Active Member
For some reason my card isn't updating entitlements whilst plugged into the Omnikey 3121 (using OSCAM 1.10 svn6089 Stable and ACAMD 0.6.2.0). I updated them with a Sky+ box tuned to Pick TV +1 for 24 hours when I first got the card, but I did the same with it in the Omnikey last night and nothing. First entitlements expire in three weeks so need to get this sorted! Here's my OSCAM files - am I missing something here?

...

Today it's been tuned to Pick TV +1 for a few hours and the OSCAM web interface shows absolutely no EMMs received at all (none blocked, none skipped, none written, none error). From looking at other posts on other forums, something should've happened as some providers send global EMMs every minute! :(
Hi,

can you go into the oscam webpage, then stop and start the service.

Then upload the log details that appear on the status page.

Tony
 

DragonQ

Novice Member
Code:
2012/05/27 16:12:57 11481C0 s >> OSCam << cardserver started, version 1.10rc-svn, build #6089 (i386-pc-cygwin) 
2012/05/27 16:12:57 11481C0 s version=1.10rc-svn, build #6089, system=i386-pc-cygwin, nice=-1 
2012/05/27 16:12:57 11481C0 s client max. idle=120 sec, debug level=0 
2012/05/27 16:12:57 11481C0 s max. logsize=2048 Kb, loghistorysize=4096 bytes 
2012/05/27 16:12:57 11481C0 s client timeout=5000 ms, fallback timeout=2500 ms, cache delay=120 ms 
2012/05/27 16:12:57 11481C0 s services reloaded: 0 services freed, 5 services loaded, rejected 0 
2012/05/27 16:12:57 11481C0 s userdb reloaded: 4 accounts loaded, 0 expired, 0 disabled 
2012/05/27 16:12:57 11481C0 s signal handling initialized (type=sysv) 
2012/05/27 16:12:57 11481C0 s 1002 service-id's loaded in 1ms 
2012/05/27 16:12:57 11481C0 s can't open file "C:\oscam/oscam.tiers" (err=2 No such file or directory), no tier-id's loaded 
2012/05/27 16:12:57 11481C0 s 11 provid's loaded 
2012/05/27 16:12:57 11481C0 s can't open file "C:\oscam/oscam.ird" (errno=2 No such file or directory) irdeto guessing not loaded 
2012/05/27 16:12:57 11481C0 s monitor: disabled 
2012/05/27 16:12:57 11481C0 s camd33: disabled 
2012/05/27 16:12:57 11481C0 s camd35: disabled 
2012/05/27 16:12:57 11481C0 s cs378x: disabled 
2012/05/27 16:12:57 11481C0 s newcamd: initialized (fd=6, port=15008, crypted) 
2012/05/27 16:12:57 11481C0 s CAID: 0963 
2012/05/27 16:12:57 11481C0 s provid #0: 000000 
2012/05/27 16:12:57 11481C0 s radegast: disabled 
2012/05/27 16:12:57 11AD888 h HTTP Server listening on port 8181 
2012/05/27 16:12:57 11481C0 s http thread started 
2012/05/27 16:12:57 11481C0 s creating thread for device 0 
2012/05/27 16:12:57 11B86D8 r reader thread started (thread= 11B86D8, label=cam1, device=0, detect=cd, mhz=357, cardmhz=357) 
2012/05/27 16:12:57 11481C0 s loadbalancer: can't read from file /Users/Adam/AppData/Local/Temp/_oscam/stat 
2012/05/27 16:12:57 11481C0 s waiting for local card init 
2012/05/27 16:12:58 11B86D8 r cam1 card detected 
2012/05/27 16:12:58 11B86D8 r cam1 ATR: 3F FD 13 25 02 50 00 0F 33 B0 0F 69 FF 4A 50 D0 00 00 53 59 02 
2012/05/27 16:12:59 11B86D8 r [videoguard2-reader] classD0 ins36: returned unknown type=0x06 - parsing may fail 
2012/05/27 16:12:59 11B86D8 r [videoguard2-reader] parental lock setting: 3F 00 0E 00 
2012/05/27 16:12:59 11B86D8 r [videoguard2-reader] type: VideoGuard BSkyB (0963), caid: 0963 
2012/05/27 16:12:59 11B86D8 r [videoguard2-reader] serial: xxxxxxxx, BoxID: xxxxxxxx, baseyear: 1997 
2012/05/27 16:12:59 11B86D8 r [videoguard2-reader] ready for requests 
2012/05/27 16:12:59 11B86D8 r found cardsystem videoguard2 
2012/05/27 16:12:59 11B86D8 r [videoguard2-reader] cam1 card detected 
2012/05/27 16:12:59 11B86D8 r [videoguard2-reader] type: VideoGuard BSkyB (0963) 
2012/05/27 16:12:59 11B86D8 r [videoguard2-reader] tier: 0003, expiry date: 2012/06/18-00:00:00 
2012/05/27 16:12:59 11B86D8 r [videoguard2-reader] tier: 000b, expiry date: 2012/06/18-00:00:00 
2012/05/27 16:12:59 11B86D8 r [videoguard2-reader] tier: 001d, expiry date: 2012/06/18-00:00:00 
2012/05/27 16:12:59 11B86D8 r [videoguard2-reader] tier: b765, expiry date: 2012/06/30-00:00:00 
2012/05/27 16:12:59 11B86D8 r [videoguard2-reader] tier: b766, expiry date: 2012/06/30-00:00:00 
2012/05/27 16:12:59 11B86D8 r [videoguard2-reader] tier: b772, expiry date: 2012/06/30-00:00:00 
2012/05/27 16:12:59 11B86D8 r [videoguard2-reader] tier: b773, expiry date: 2012/06/30-00:00:00 
2012/05/27 16:12:59 11B86D8 r [videoguard2-reader] tier: b860, expiry date: 2012/06/18-00:00:00 
2012/05/27 16:13:00 11481C0 s init for all local cards done 
2012/05/27 16:13:00 11481C0 s anti cascading disabled
And when I start timeshifting an ecrypted channel:

Code:
2012/05/27 16:14:41 11B9C88 c client connected to 15008 port 
2012/05/27 16:14:41 11B9C88 c encrypted newcamd:15008-client 127.0.0.1 granted (USER1, au=on (1 reader)) 
2012/05/27 16:14:41 11B9C88 c user USER1 authenticated successfully (ACamd) 
2012/05/27 16:14:41 11B9C88 c AU enabled for user USER1 on reader cam1 
2012/05/27 16:14:41 11B9C88 c housekeeping lb stats thread started 
2012/05/27 16:14:41 11B9C88 c USER1 (0963&000000/13F3/68:71C6): found (110 ms) by cam1 (of 1 avail 1) 
2012/05/27 16:14:41 11B9C88 c USER1 (0963&000000/13F3/68:71C6): cache1 (120 ms) by cam1 (of 1 avail 1) 
2012/05/27 16:14:41 11B9C88 c USER1 (0963&000000/13F3/68:71C6): cache1 (120 ms) by cam1 (of 1 avail 1) 
2012/05/27 16:14:49 11B9C88 c USER1 (0963&000000/13F3/68:5582): found (105 ms) by cam1 (of 1 avail 1) 
2012/05/27 16:14:57 11B9C88 c USER1 (0963&000000/13F3/68:1E13): found (105 ms) by cam1 (of 1 avail 1) 
2012/05/27 16:15:04 11B9C88 c USER1 (0963&000000/13F3/68:5D40): found (100 ms) by cam1 (of 1 avail 1)
...
And what the Readers webpage says after a few hours of being tuned to an encrypted channel (this was taken only a few minutes in but it looks the same after a few hours):

 
Last edited:

tony_park

Active Member
Hi,

usually I see updates anywhere between 2-4 weeks before expiry, so I'd revisit in about 10 days time or so. If they aren't refreshing, you can always stick your viewing card back in your sky box for an evening, and that will update them.

I don't think Sky update their entitlements as often as other providers.

Tony
 

DragonQ

Novice Member
Well my first entitlements expire in 19 days so I'd expect them to be updated fairly soon.

I find it very hard to believe that Sky haven't broadcast any EMMs (including global ones) in the last 3 days. But that's what the OSCam web interface is showing. I'd appreciate anyone using OSCam with a Sky card commenting on what they see on the Readers tab of their web interface (and also which build of OSCam they are using - I'm using the OSCAM-1.10svn6089-i386-pc-cygwin-libusb-pcsc-webif Windows build).
 

ChileanLlama

Novice Member
DragonQ, what is your billing date from Sky? You should expect to see your entitlements update shortly after your billing date, and extend them about 4-6 weeks if it's working correctly.

My setup is different to yours in that I'm using a DM500 as the card reader, so it's an altogether different Oscam build (not i386). But it's 1.00 build 4863. It's working great, and just checking now it's moved my entitlements on to 22/07 in the last day or so.
 

DragonQ

Novice Member
I don't have a billing date, I just have a Freesat From Sky card which has no subscriptions - it only allows you to view the 8 or so free-to-view (FTV) channels.

I've done some experimenting and have managed to get EMMs sent to OSCam by switching from acamd (which uses the newcamd protocol) to Hadu (which I believe is a CCCam client that uses the CCCam protocol). No unique EMMs yet but lots of global ones (which are being blocked by OSCam) so I'm hopeful. I guess acamd is just broken when it comes to EMMs and since it hasn't been updated since late 2010 I guess it's not a good idea to use it anyway!

If it all works out, I'll talk to Robbo about maybe updating the MediaPortal guide, since I think I remember him saying he doesn't have EMMs working either.
 
Last edited:

tony_park

Active Member
I don't have a billing date, I just have a Freesat From Sky card which has no subscriptions - it only allows you to view the 8 or so free-to-view (FTV) channels.

I've done some experimenting and have managed to get EMMs sent to OSCam by switching from acamd (which uses the newcamd protocol) to Hadu (which I believe is a CCCam client that uses the CCCam protocol). No unique EMMs yet but lots of global ones (which are being blocked by OSCam) so I'm hopefuly. I guess acamd is just broken when it comes to EMMs and since it hasn't been updated since late 2010 I guess it's not a good idea to use it anyway!
When I used a omnikey card reader, using OSCAM and acamd, I had entitlements updating - but I have a Sky subscription, not a freesat card. There were no problems regarding that aspect.
 

Similar threads

Trending threads

Latest News

Disney CEO Bob Iger steps down
  • By Andy Bassett
  • Published
Quantum Dot development could mean cheaper displays
  • By Andy Bassett
  • Published
Netflix launches daily top ten rankings
  • By Andy Bassett
  • Published
OLED TV sales exceed one million in Q4 2019
  • By Andy Bassett
  • Published
Bowers & Wilkins CEO leaves amid restructuring
  • By Andy Bassett
  • Published
Top Bottom