How to play avi/xvid/divx files in Media Centre?

Discussion in 'Desktop & Laptop Computers Forum' started by Devster1, Jan 22, 2008.

  1. Devster1

    Devster1
    Standard Member

    Joined:
    Jan 12, 2007
    Messages:
    60
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    8
    Ratings:
    +1
    Does anyone know how to get avi files to play in Windows Media Centre on Vista 32-bit?

    Has anyone managed to get this working??!! :suicide:

    I have tried a few avi files I would like to play in Media Centre, but when I go to the directory in MC that contains the avi files, MC states that no videos were found? I have tried installing ffdshow and media control plugin, but I still cannot get MC to recognise my avi's :confused:

    Its driving me nuts, I am sure there are many other people who would like to get this working, someone please help! A 'How to' guide from someone would be splendid :thumbsup:

    :lease::lease::lease:
     
  2. md1542

    md1542
    Active Member

    Joined:
    Jul 13, 2005
    Messages:
    312
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    28
    Location:
    Gloucester
    Ratings:
    +54
    By default, you can't. Windows Media Center doesn't support Xvid or DivX files. However, there's a 3rd party plugin you can use that apparently does the trick. You can download it here:

    http://damienbt.free.fr/index.php#download

    If you want to read about it first, check this "review" out:

    http://www.onetipaday.com/2007/05/28/how-to-play-xvid-and-avi-files-with-vista-media-center/

    I've never tried it myself, as I used WMP11....but according to those sites - it does what you want. Would be interested to see the result, so let me know how it goes!
     
  3. tinners

    tinners
    Well-known Member

    Joined:
    May 22, 2006
    Messages:
    3,288
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    106
    Location:
    Bucks
    Ratings:
    +242
  4. Devster1

    Devster1
    Standard Member

    Joined:
    Jan 12, 2007
    Messages:
    60
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    8
    Ratings:
    +1
    This is exactly what I have tried. It didnt work :thumbsdow

    The media control never worked, and after installing ffdshow, Media Centre wouldnt even play mpeg videos (it did before). It caused media centre to crash saying the ffdshow codec was the problem.
     
  5. Devster1

    Devster1
    Standard Member

    Joined:
    Jan 12, 2007
    Messages:
    60
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    8
    Ratings:
    +1
    Thanks tinners, this looks interesting. Could you give a few more steps on how to do this? Also I presume a codec pack is required to play all these file types?

    Or can I just modify the registry and thats it?
     
  6. tinners

    tinners
    Well-known Member

    Joined:
    May 22, 2006
    Messages:
    3,288
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    106
    Location:
    Bucks
    Ratings:
    +242
    you should only need ffdshow (You DONT need mediacontrol) to play DIVX XVID etc.
    Uninstall ffdshow, mediacontrol and then just install
    http://ffdshow-tryout.sourceforge.net/

    Check you can play all your files in Windows Media Player. If so then your codecs are OK.

    Then run the registry changes and the files should appear in the videos area of media center. Again you can check this by adding the folders in Windows Media Player and seeing if the files show up.


    MediaControl allows ffwd / rewd in media center. Works OK on my HTPC with ffdshow tryouts. Only install this when all else is OK.
     
  7. Devster1

    Devster1
    Standard Member

    Joined:
    Jan 12, 2007
    Messages:
    60
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    8
    Ratings:
    +1
    thanks tinners, it worked :thumbsup::thumbsup:

    I have only tried .avi files so far and couldnt believe my eyes when they showed up in MC :eek:

    Just got to go through now and add all the file types to the registry and install ffdshow !

    cheers :smashin:
     
  8. J7MAN

    J7MAN
    Active Member

    Joined:
    Oct 28, 2007
    Messages:
    976
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    31
    Location:
    Mansfield, Notts.
    Ratings:
    +75
    Strange, my VMC always plays .avi's. Only had to add .mkv's to the registry.
     
  9. Stiggy

    Stiggy
    Well-known Member

    Joined:
    Dec 7, 2004
    Messages:
    6,725
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    136
    Location:
    Sandy Heath
    Ratings:
    +1,043
    Some of you seem to be making this overly complicated. To play DivX/Xvid, just download and install the DivX/Xvid codec! I had problems with the latest version of DivX, but Xvid works fine.
     
  10. y2k

    y2k
    Well-known Member

    Joined:
    Jan 3, 2008
    Messages:
    3,300
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    106
    Location:
    Banana Republic
    Ratings:
    +291
  11. tinners

    tinners
    Well-known Member

    Joined:
    May 22, 2006
    Messages:
    3,288
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    106
    Location:
    Bucks
    Ratings:
    +242
    but that's not in media center ;)
     
  12. y2k

    y2k
    Well-known Member

    Joined:
    Jan 3, 2008
    Messages:
    3,300
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    106
    Location:
    Banana Republic
    Ratings:
    +291
    :oops: again
     
  13. SHAHZ

    SHAHZ
    Standard Member

    Joined:
    May 6, 2006
    Messages:
    24
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Thanks for the link tinners, just what i needed:thumbsup:
     
  14. beltona

    beltona
    Standard Member

    Joined:
    May 5, 2008
    Messages:
    1
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    1
    Ratings:
    +0
    hi there new to this having the same problem.did you get it to work if so could tell me how ,many thanks helen
     
  15. Devster1

    Devster1
    Standard Member

    Joined:
    Jan 12, 2007
    Messages:
    60
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    8
    Ratings:
    +1

Share This Page

Loading...