How to get "enhanced 4K" and "input signal plus" to work together?

Punisa

Novice Member
I use my home theatre almost exclusively for movie watching, but since I got a new TV (Samsung Q65T - long version name: qe55q65tauxxh) I'm having a difficult time setting it all up, especially if I want to get the best picture possible. My simplified setup is as follows: HTPC (Nvidia GTX 1050 Ti) -> HDMI -> AVR (Marantz 6013) -> HDMI -> Samsung TV.

There is an option on Marantz to choose between standard 4K and "enhanced 4K". On my TV there is an option to enable "input signal plus" for my HDMI port. When I choose both "better" options there is no signal. I can get signal only if I disable either "enhanced 4k" on AVR or "input signal plus" on TV. Well, that doesn't sound good, right? I would guess something is causing a problem in my chain, but I can't figure out what.
Any help/suggestions are appreciated.
 

gibbsy

Moderator
You certainly need to have Enhanced 4K on the Marantz for pass through of 4K and HDR signals. Check on the TV when watching HDR content confirming it as HDR/HLG with input signal plus turned off. There is probably a conflict between the Marantz and TV with both turned on but Enhanced on the Marantz is more important.
 

The latest video from AVForums

Podcast: Sony A90J Thoughts, madVR Processor & Sonus faber Lumina II Reviews + Movie & TV roundup
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom