1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

HomePlug PL-85PE & NeverWire 14 powerline adapters - How to config & work together ?

Discussion in 'Desktop & Laptop Computers Forum' started by NutKracker, Oct 1, 2005.

  1. NutKracker

    Standard Member

    Dec 7, 2003
    Products Owned:
    Products Wanted:
    Trophy Points:

    I need some help with regards to configuring the HomePlug PL-85PE so that it can work along with the legacy NeverWire 14.

    I've had the NeverWire 14 units for a couple of years but just recently, one of them died on me. So I've gone and purchased a HomePlug PL-85PE adapter (85Mbps) on the understanding that it's backward compatible.

    The Neverwire units worked straight out of the box - no setup/configuration required. I was under the impression that the PL-85PE unit would be the same.

    So how do you get these two devices working together ? I've contacted Solwise support and they've informed me that the Neverwire unit needs to have it's security settings defaulted back to the original setting (secure light flashes every 5 secs). This apparently sets the password to be HomePlug. I've done this, but I still can't get the two units to talk to each other.

    I've also attempted to use the PowerPacket software that comes with the PL-85PE - but the software is unable to find the adapter - when it's connected to a hub and when it's connected directly to the PC.

    So I'm currently at a loss as to what else I can try. Any suggestions gratefully received!



Share This Page