Quantcast

Home automation: BTicino, OpenWebNet, SCS bus

djtom2002

Novice Member
My installers gave me an example project file for MH202 for scenarios and weather sensors. I loaded it into Myhome and will check it out and compare it with what I have done. I could provide a dropbox link via PM if anyone is interested.
First of all. Hi Everybody. I am also here from bticino forum. Same nickname :)

I hope everone is fine.

Mark, i would be interested in the example project file for mh202, if you could share it, it would be great. I am also not sure, if you already had the possibility to post about your schalk sensors? I think i also might have overread it ;)

My settings are still the same since beginning of 2017, but now i need to increase the functionalities due to weather (wind, temperature, etc.)

br
Tom
 

m4rky_m4rk

Member
Just PM me and I will send a Dropbox link.Then you need to add another MH202 into your project and then right click on the new MH202 icon and select import project. This avoids overwriting your existing project!! I have a BTicino explanation which I scan and send too.

I checked what was in there and its quite simple... you could probably do better yourself :)

I did write a lot above but if want to know more I will post more... no problem :) My rain sensor is permanently On now.. Probably becasue the installer removed the protective plastic and shouldn't have. I await a replacement.


Question........... also the same in my last post.
I am using a boolean to allow blind scenarios to run or not.. A master override of sorts. I added it as 'only if' condition and a 'stop' event to all blind scenarios that can directly move the blinds. It's not only useful for safety reasons when working on the blinds but my Wind sensor scenario uses it to stop the blinds being moved by other scenarios when there are high winds.

To display the status of this boolean I am using a spare actuator which is triggered on or off depending on the boolean state.. 1 (run)=true or false.

My problem is that the actuator can also be turned on and off with the Gen command. I think I can prevent that by setting the actuator to master pulse. But is this the best way??
 

m4rky_m4rk

Member
Another question... I am setting up the MyHome screen 10 panel... Any tips for setting it up?

Can the displayed room and floor order be changed? The display seems to show them in the order I add them.

I notice that some settings are done via MyHomeSuite and others are done directly on the panel eg card picture.

Also, the browser always shows 'Experimental' in the top right corner and when browsing not only is it slow but there are frequent warning messages about 'untrusted SSL connection'.... in other words the browser is a big disappointment and almost useless.
 
Last edited:

djtom2002

Novice Member
I also never used the browser butnoticed that same settings are better to be done on the panel. I also displayed my internal temperature sensor on the panel.
 

bastler

Novice Member
hi mark, sorry for not answering so long, my openhab drives me crazy!
i also use the 10" myhomescreen. but never used the webbrowser for the same reasons that you noticed already. i also had to change the card-pics direct on the panel, and didn´t find out how to sort the rooms order.
nice weekend to all! stefan
 

m4rky_m4rk

Member
I did notice port 22 is open, I found the login user name and password. I can connect and wondered if it was possible to change, tinker with a few things.. eg browser. It looks like BTicino are not developing the panel since I see no update for a year even though the browser says 'experimental'. Anyone done anything with linux and the panel?
 

m4rky_m4rk

Member
am "sxpertle" there
looks like you need to use the usb port in the back to configure the 300x with MHS
I can't try at the moment, but will do as soon as I get close to a screen 10

I tried that. MyHome still crashes whenever I tried to access the the config. I did try without bus power so maybe it needs to on the bus and USB connection.
 

m4rky_m4rk

Member
hi mark, sorry for not answering so long, my openhab drives me crazy!
i also use the 10" myhomescreen. but never used the webbrowser for the same reasons that you noticed already. i also had to change the card-pics direct on the panel, and didn´t find out how to sort the rooms order.
nice weekend to all! stefan

No problem. I hope posting here, this thread or another, doesn't just turn out to my own personal support threads. I would like to encourage chatter from other like minded folks. We need to encourage others to come over here to get it above a critical mass... if not the community chatter will fade. Please try get some of the others over here.

Yet again when asking questions on the MyOpen community forum I get told by the mods to refer to my installer.....its annoying.
 

m4rky_m4rk

Member
hi mark, sorry for not answering so long, my openhab drives me crazy!
i also use the 10" myhomescreen. but never used the webbrowser for the same reasons that you noticed already. i also had to change the card-pics direct on the panel, and didn´t find out how to sort the rooms order.
nice weekend to all! stefan
Hi Stefan,

I think I am going mad. I am trying to set up my screen10. I can't get cen plus commands to work at all. I am using myHome suite and find that CEN works but CEN plus not. I am sure that I saw one time that I could create scenarios directly on the panel and now I can't find how it was done at all. V frustrating eg My Home screen 10 scenarios.

The some of help page for scenario modules throws up a 'server not found 'message

Have you tried CEN plus commands?

Also I see that they can have enable and disable buttons but what goes in the address?

Mark
 

m4rky_m4rk

Member
Does anyone know if the basics contacts interface 3477 should behave differently to the DIN rack version F428? I have the contact interfaces showing on my display panel Screen10 and notice that after a display reboot/config upload some seem to need a state change before they show the correct status and some seem to correct immediately The only difference is use the type F428 vs 3477.

Also, the Screen10 home screen seems to keep loosing the temperature display on the home page. I set in the Homesuite softtware and once on the display itself but now I can't find where on the display its set. Plus now I can't find how to create a MyHomescreen10 scenarios. They get setup on the screen but now not. CENplus scenario trigger doesn't work but CEN does!!! aaagh I am going mad.

Anyone got any neat tips on how to display the state of a boolean on the Screen10. So far I am using spare relays but wondered if there was a better/cheaper way to do this.

Tom, if you pass by... The weathers sensors are proving useful. Blinds retract and all scenarios are disabled when its too windy and later after an hour of no wind they go back to normal operation. Neat. We had a bad storm recently and they behaved perfectly.
 

djtom2002

Novice Member
Hi Mark!

Thanks for information. I think i will install them in autumn this year. Regarding the Screen10 i use just some scenarios, but they work. I think the trigger is different to the mh202 starting condition, if i remember correctly.
 

gugus24

Novice Member
Hi,
I also have a house with a Bticino Myhome Installation. I have some problems with my MH202, Videophone 300X and Sfera Camera and MyHomeServer1 :
MH202 : Cannot a good tutorial how to use the boolean function and don't understand the difference CEN PLUS, CEN or Scenario modules functions.
MyHomeServer1 : The connexion is very difficult to establish with MyHomeUp. I very often get the message that the gateway not reachable is.
Videophone 300X : Very bad quality and resolution. If someone rings, my phone rings but impossible to get the image from camera.
 

jupiler

Novice Member
Hello, Just registered myself over here. I am Jeroen from Belgium and I came over here from the myopen forums.

To make my first post usefull :) I will start right away with a question.
Until now had a setup with a F454, an mh200n, 11 F411's, 3 F414's, some F430's and a 99 zone thermo unit and a lot of 4652's and 4651's.
All works more or less ok and I am able to configure my stuff using the myhome suite and for most devices the advanced configuration. I use the F454 as my gateway.
Next step in my setup is adding doorbells, camera's and screens in the house. Therefore I installed a F441 for distributing the video and move the F454 from the automation bus to and output of the F441. I linked the automation bus to the AV bus using an F422 with a 1 in I4.
Now I cannot see anything on the bus anymore from within the myhomesuite. If i use the F454's web server I can connect to the camera's and so on, but I cannot search for devices on the automation bus. Even if I do the scan where you have to press a local button on the device...

Anyone got an idea what I do wrong?
 

m4rky_m4rk

Member
MH202 : Cannot a good tutorial how to use the boolean function and don't understand the difference CEN PLUS, CEN or Scenario modules functions.
I asked a similar question on the BTicino forum but can't find it. The search on the new BTicino forum is useless. Basically Marcog replied and from what I remember the differences are more historic. The differences were do with what they would work with with hardware wise. I use a mixture of them in MH202. Cen Plus for my Phone app , CEN calling another scenario on MH202 and Homescreen10. Trial and error to find out what needs what.

Videophone 300X : Very bad quality and resolution. If someone rings, my phone rings but impossible to get the image from camera.
I have the 300x and Sfera. Seems to work OK. Is the WiFi signal good between the router and 300x? Must admit the image quality is lower than expected. I have da night camera version. The image does look better on the Screen10 so maybe its the 300x that's below par.


MH202 : Cannot a good tutorial how to use the boolean function and don't understand the difference CEN PLUS, CEN or Scenario modules functions.
Boolean.. I use them a lot. Basically you can get scenarios to start or not start based on a change of state of a boolean. So, as it a change of state of the boolean that is needed to do anything then its important to define the starting state. I do this with a scenario that just runs on restart of the MH202.(tick box in top right in myhomesuite)

eg for safety I set an override that stops all blind scenarios from running using a boolean.
For each blind scenario I have the 'only if' condition 'Run' Boolean 1 = true.

If there is someone working near the blinds or its windy I set 'Run' Boolean1=false, either manually(phone or panel) or automatically(wind), then the blinds will not move until its set back to 'Run' Boolean1=true again.

You can also use the change of state of a Boolean to trigger a scenario too.

With booleans tracking 'events' you can then create more complicated conditions for running a scenario.
eg
  • For my water irrigation pump I have to press run, stop, run on my phone. I did this so I do not accidentally set the pump running.
  • If someone is using the patio they can press, up, down, up on the blind control button and this will stop the blind closing automatically when the house too hot, its dark etc
  • Wind=false is only set if the wind sensor contact has been open for 30mins. Then blinds can run again.
 
Last edited:

gugus24

Novice Member
Hi M4arky,
Thank you very much for all those answers !!! It is good to see that somebody helps !
Regarding the Wifi, I have only two lines indicated. I tried to put a repeater to get a stronger signal, but it doesn't help.
For the boolean problem I will try some tests but if you have some concrete examples how they are encoded in the MH202, they would be helpful. :)
 

m4rky_m4rk

Member
Hi M4arky,
Thank you very much for all those answers !!! It is good to see that somebody helps !
Regarding the Wifi, I have only two lines indicated. I tried to put a repeater to get a stronger signal, but it doesn't help.
For the boolean problem I will try some tests but if you have some concrete examples how they are encoded in the MH202, they would be helpful. :)
Repeater should help.

Boolean is really simple. Maybe you are over thinking it. There is nothing much to encode.

eg.
My blinds close in stages depending on the internal temperature and if its sunny.
  • Scenario partial close
  • Scenario full close
I use booleans to prevent the blinds repeatedly going back and forth between full and partial closed positions e.g. if blinds fully close and then the room cools a bit.

Like this
Scenario 'fully close blinds' sets a boolean 'fully close' to true
Scenario 'partially close blinds' only runs only if Boolean 'fully closed' = false
When the blinds are opened again then the booleans indicating blind state are reset
 

m4rky_m4rk

Member
M4rky,
is it possible to see the state of a boolean counter ?
Yes but BTicino do not make it easy. Checking the state of booleans' would make life a lot easier.

I have Screen10 panel. It can show if an actuator is open or closed. Normally that would be to show if a light is on or off. I used some spare actuators connected to nothing and set them to open or close depending on a boolean state. So I get a green indicator if a Boolean is true. I only do this for really important booleans eg Master off, auto run.
A slight problem with that is the display shows the boolean indicator as switch and someone... not saying who ....could switch it on/off by mistake... So, I used another scenario and the boolean to switch it immediately back to reflect the correct boolean state... A nice but more expensive way would be to use a Basic contact interface module as well as actuator. The screen10 can show the state of the contact module and user cannot accidentally change the state on the panel.

Its possible to set the start conditions for several scenarios to be the same and use 'only if' condition to decide which one is actually run.

A tip for debugging. The web admin page of the MH202 shows which scenarios are currently running.
 

gugus24

Novice Member
M4rky, can you please show me an example with Print Screen how you integrate the boolean for recording that the blinds are fully closed ?
 

gugus24

Novice Member
Hi M4rky,
As expect I tried to use the boolean and that 's my result :
  • Boolean with the True/false value -- > wroks fine (as not so difficult to program it)
  • Counter : Impossible to make it work.
Here is the scenario I just realized to test the Counter :

When I turn on the garage lights 3 times, the kitchen light should turn on.

1. Creation of 1 Scenario for my Counter :
Start Area :
  • Garage Light -> ON
Action Area :
  • Command -> Value+ | Step -> 1
  • Address -> Counter 1

2. Creation of 1 Scenario to Turn on the kitchen lights

Start Area :
  • Garage Light : -> ON
Condition :
  • Command -> Variable Value
  • Condition -> '='
  • If Value -> '3'
  • Address -> Counter 1
Perhaps you will find my mistake....
In advance I thank you a lot
 

m4rky_m4rk

Member
Hi M4rky,
As expect I tried to use the boolean and that 's my result :
  • Boolean with the True/false value -- > wroks fine (as not so difficult to program it)
  • Counter : Impossible to make it work.
Here is the scenario I just realized to test the Counter :

When I turn on the garage lights 3 times, the kitchen light should turn on.

1. Creation of 1 Scenario for my Counter :
Start Area :
  • Garage Light -> ON
Action Area :
  • Command -> Value+ | Step -> 1
  • Address -> Counter 1

2. Creation of 1 Scenario to Turn on the kitchen lights

Start Area :
  • Garage Light : -> ON
Condition :
  • Command -> Variable Value
  • Condition -> '='
  • If Value -> '3'
  • Address -> Counter 1
Perhaps you will find my mistake....
In advance I thank you a lot
I posted a reply here

BTicino MyHome bus: MH202 advanced scenario controller

When I get time I will move the other MH202 scenario posts from this general thread to the new dedicated one
 

djtom2002

Novice Member
I also saw that there is a new bticino product called smarther for temperature. Does anyone of you have it already and how doeis it work?

And my last question: does anyone have the f459 for weather issues as there is stilll the problem that it is not sold in a lot of countries...
 

geoffbs

Novice Member
I've also just joined the forum having not had any success in getting responses on the MyOpen forums. I've read through the posts here and seems like people really want to help which is great.

I've just had a MyHome system installed in my new house primarily to control lighting and blinds. The system was installed by an installer using the hard configurators using rather than the virtual method which is the way i want to go now.

I've just purchased and installed the F454 web server and connected it to the SCS bus. However I have a problem when I log in via through MyHome Suite through my network using ip address 192.168.1.35 (I don't use a crossover ethernet cable). It seems to connect however I immediately get the message "Plant disconnected: connection to remote host lost" and it doesn't retrieve any information from the system.

I can login to the F454 webserver directly but all I see via the portal is a single configuration under lighting called "Gen1" which only allows all the lights on and off together but no individual control.

Any ideas, thanks?
 

Trending threads

Latest News

Sky announces price rises for UK
  • By Andy Bassett
  • Published
LG Display OLED panel production below forecasts
  • By Andy Bassett
  • Published
Panasonic launches SC-HTB600 and SC-HTB400 soundbars
  • By Andy Bassett
  • Published
Panasonic launches HX940 and HX800 4K LCD TVs for 2020
  • By Andy Bassett
  • Published
Top Bottom