Holy Stone Drone Issues - Doesn't want to fly right


I purchased my first drone, the Holy Stone HS700D new, off facebook marketplace unfortunately. I didnt realize without an Amazon order number I cant even get the warranty on the drone or get a replacement. Anyways, I have discovered that the drone does not like to fly forward, and when it does it does not fly further than about 56ft and seems to hit some kind of invisible wall. If i preform a "Trace Route" on a GPS map it will fly to the quantum realm and back but only then. The drone flies backwards very well... It will not fly higher than 52ft unless I hit "Return To Home" and it climbs high and I cancel it while it is still high. Also it will not rotate unless it is within about 10ft of me. I have tried turning GPS off, 5 different locations, and have an average of 17 satellites each flight. Holy Stone's Support department doesnt reply to anything. I did see another users post regarding this and they said when they did not connect their phone for FPV the drone flew much better like normal and was able to resolve this issues. My question is has anyone else experienced these kind of issues with other HS drones, or other drones in general, and what was the solution?

I've attached a clip recording of my FPV view on a drone flight for you to see.


Active Member
It sounds like it is set in some sort of training mode which, as paulyoung666 above says likely to be geofenced for that reason.


Novice Member
Just want to reply to this thread since it's hard to find resources on this issue... What OP describes happened to me as well. Drone (HolyStone 720E using the Ophelia app) worked fine without FPV on but was severely limited in FPV mode. The manual did not address this in any way, but the default in FPV settings place severe restrictions on distance and altitude (Beginner Mode). You have to change these settings. Don't assume that the drone functions are normal after an initial, modest test flight and then encounter control problems when you attempt a more ambitious flight. In my case, before I realized what was going on, the drone went out of the zone within which it was responsive to controls and then drifted into a tree. Yikes. So @Bryn1 is correct.

The latest video from AVForums

AVForums Movies Podcast: Streaming Theatrical Releases And The Future Of Cinema
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom