Quantcast

HK DVD 506 Subtitle Problem

Bonce

Standard Member
Hi,

I watched Kill Bill last night, and found that my DVD player (HK 506LE) didn't automatically display English subtitles for the frequent sections of Japanese dialogue. In the end I had to turn subtitles on permanently which was very distracting in the English dialogue sections. I also encountered this problem with German dialogue in The Pianist, so I know it’s the player and not the disk. Is there anything I can do about this?

Sorry if this is digging up an old topic but I searched the archives but couldn’t find a definitive answer, only some alarming hints that I might lose Multi Region capability if I upgrade the firmware!?

Thanks for any tips.
 

Bonce

Standard Member
Has no-one else experienced this problem then?

Could any other HK DVD owners please test either Kill Bill or the Pianist and see if they have the same problem? I have received an email from Harman UK saying that they have not heard of this problem before.

Cheers!
 

Londondecca

Active Member
I had the same problem, I had just bought my DVD30 and rented Kill Bill that night, only fixed it half way through the film by going into the set-up menu and switching on the subtitles.
 

Bonce

Standard Member
Hmm, it's good to know that I'm not alone, but it's still frustrating. I have upgraded my firmware and it hasn't fixed the problem.
 

Londondecca

Active Member
Just as a follow up to this thread, I have found a number of other people who also had problems with the subtitles on Kill Bill, so I dont think it is related to HK
 
C

cjmurph

Guest
I have a 506 LE and have had this problem since I first plugged it in. I initially found the issue with ALL of the star wars disks, and later kill bill. To go further, with the original star wars disks (episode 4, 5, 6) the subtitle options are unavailable completely both in the disk menu and while playing the movie. the only way to get subtitles is to turn them on in the player menu, and then you have them all the time :mad: not just when an alternate language is spoken. I have been in contact with the Australian importer with regard to this for the last 3 months. Today (finally) they called me to say that they have sent a disk with a firmware upgrade to fix the problem. until it arrives though, the jury is still out. I'll post an outcome if or when it happens.

With regard to the region on the player; it can be set using the following method: with no disk in the tray, and the remote in your hot little hand, press "osd", then 314159 (first 5 digits of pi), followed by 0-6 (for the appropriate region), it will set the region you desire (0 being multi).
 

Bonce

Standard Member
Hi, Please keep me posted on whether this firmware upgrade fixes the problem, it bugs the hell out of me!
 

Astaroth

Well-known Member
Bonce - are the disk that you are using UK sourced or from "the country who's language the subtitles are showing in?"

Whilst I have a different DVD player I have recently bought a couple of disks from our european friends and have found that on the english tracks the DVD is automatically putting up subtitles in the language of the country I have bought the disk from and whilst I can turn it off the Mrs can struggle..... the player options are not to show subtitles but the disk appears to over ride this option!?!?
 
C

cjmurph

Guest
IT WORKS!!!!!!
Today I finally got a hold of the firmware from the importer here in AUS. funny enough it was for a DVD22. Still I did the upgrade, and low and behold it fixe dthe subtitles in the original star wars series. and thats where the good news stopped. still not working in Kill Bill or star wars ep 1 & 2. so I thought, to hell with it, I'll install the region 2 firmware update (for the 506) I downloaded online. and what do you know, once installed, everything works. I don't know if it is a combination of the two but my player works now. the 506 update is available here: http://www.harmankardon.com/product...uage=ENG&cat=&prod=DVD 506/230&sjump=&#active

I anyone wants the first update I tried (from importer), give me your email address and I'll send it along :thumbsup:
 

Similar threads

Top Bottom