1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Hitachi TX100 blurring problem

Discussion in 'Projectors, Screens & Video Processors' started by mjhammond, May 30, 2005.

  1. mjhammond

    mjhammond
    Standard Member

    Joined:
    May 30, 2005
    Messages:
    49
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    8
    Location:
    London
    Ratings:
    +3
    The problem stems form a few weeks back when I had a movie night with some mates, unfortunately more alcohol was consumed than should have been, which ended up in someone spilling Reef onto the lens (!!!). I managed to clean the foul sticky liquid off the lens with a lens cloth, luckily avoiding any serious damage, but ever since then i have noticed blurring of the outer edges of the image. When I look at the lens from an angle whilst the pj is running, i can notice what looks like a smear accross the front of the lens.
    The lens coating appears not to have been damaged, so i suspect the blurring is due to this smear, i've tried cleaning it off with a dry lens cloth (which the manual suggests) but to no avail.
    Does anyone have any suggestions how to properly clean the lens?
     
  2. PJTX100

    PJTX100
    Well-known Member

    Joined:
    Dec 21, 2004
    Messages:
    8,129
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    136
    Ratings:
    +562
    If it were me I'd be trying a damp cloth of some sort...PJ :)
     

Share This Page

Loading...