Hitachi Plasma - noise when it displays white - PLEASE HELP!

Discussion in 'Plasma TVs Forum' started by midknight, Jul 12, 2004.

  1. midknight

    midknight
    Well-known Member

    Joined:
    Oct 8, 2000
    Messages:
    4,747
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    136
    Location:
    Billingshurst, West Sussex
    Ratings:
    +1,435
    Hi,

    I bought a 42' Hitachi plasma at xmas and upto about a week ago it has been fantastic - no problems at all, however recently it has developed a strange fault.

    Whenever there is bright white on screen (either on and advert of tv show) it REALLY buzzes.

    If I put the all white screen saver up it also really buzzes but then after a while it stops.

    Is it broken - do I need to contact Hitachi?

    Please help - any advice greatly appreciated.
     
  2. kheldar

    kheldar
    Standard Member

    Joined:
    Jun 15, 2004
    Messages:
    14
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    1
    Ratings:
    +0
    try to search in this forum with keywords
    "hitachi" and "buzzing"
    and you find postings from people having some similar problems.

    Probably one of the coils on the transformator circuit is starting to buzz. My Hitachi was buzzing from the beginning. I contacted Hitachi to complain, they came to fetch it 2 weeks ago and gave me a temporary replacement till mine is fixed. I suppose you check with hitachi and explain your problem, and convince them to come and replace the buzzing coil.
     

Share This Page

Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice