• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

Hitachi PD6600 HD Plasma - Seeing Red!!!

Kris100

Standard Member
I am currently on my 3rd replacement model of 6600 and still have red specs constantly flashing over the entire screen, either when I watch Television channels or DVD.

I have changed setting constantly and tried top-end scart leads also.

Has anyone else experienced this or am I cursed?

Thanks
 
T

Tainted

Guest
Is this when you turn it on and does it go away after the screen has been on for awhile?
 
B

Bosco

Guest
I was experiencing the same problem with mine, it's all down to the signal strenght, if you have your set-top box connected to your DVDR or Video and then out of that into the Hitachi you will get the red dots, try connect direct to the TV to see whether that cures it (it did for me but makes recording anything a bit of a pain).
 
K

KEVINRAH

Guest
Kris100 said:
I am currently on my 3rd replacement model of 6600 and still have red specs constantly flashing over the entire screen, either when I watch Television channels or DVD.

I have changed setting constantly and tried top-end scart leads also.

Has anyone else experienced this or am I cursed?

Thanks

I get green on mine. It seems to come and go. Decided to send it back and get a panny.
 

The latest video from AVForums

SVS Prime Wireless Pro Powered Speakers - Review Coming Soon
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom