Hitachi P50A102A plasma TV problem

Discussion in 'Plasma TVs Forum' started by n95k, Jul 30, 2012.

  1. n95k

    n95k
    Standard Member

    Joined:
    Jul 30, 2012
    Messages:
    3
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Greetings all, wealth of knowledge here and happy to join the forum. My 50" TV blew-up and following is the explanation, hope that you all can advise me on the next steps; :)

    The TV was on a HD channel when I heard a noise like HV arcing. and picture went blank, sound is on. The green led flashes three times then a pause then repeats three times this is ongoing.

    Taking a cue from the this forum & trouble shooting I found the error to be Y-SUS, SDM board related problem, and started isolating power and ribbon cables to boards, found that it was the Bottom scan driver board (had ic M16 'L6V52192' with a small hole on it) and the TV switches ON when I remove the SDR-D but makes a whining noise which I assume is a complain from the PSU that board is missing, haven't had it on for more than few seconds.

    I have ordered a replacement SDR-D (P/N P#JA31332-B) for $95 and it will take a couple of days.

    Now to my question, generally will the TV work after I replace the SDR-D board or does the ic blowup a cause of something else failing on the Y-SUS or PSU? Should I also replace the SDR-U (top) driver board also?

    Your advise/help will be greatly appreciated.

    /NK
     
  2. n95k

    n95k
    Standard Member

    Joined:
    Jul 30, 2012
    Messages:
    3
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Hi Still waiting for advise from the experts, many reads so hope someone will answer. This is more I found;

    If only the bad SDR-D is removed the 'va' and 'vs' voltages are stable and within tolerance. However the PSU switcher makes a high pitched whining noise, so I assume that something else is drawing current on the Y-SUS board, any ideas?
     
  3. n95k

    n95k
    Standard Member

    Joined:
    Jul 30, 2012
    Messages:
    3
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Hi All, replaced the Y-sus and the SDR-D boards still no luck, the power led blinks thrice, have completely run out of ideas, please help? :confused:
     

Share This Page

Loading...