Hitachi HDR5T01 (T7655) troubleshooting/fixing - next steps?

Dzzbob

Novice Member
Hello all,

I would be very grateful for any suggestions on next steps to try fixing a faulty Hitachi HDR5T01 unit which initially had intermittent freezes on recorded video playback, then refused to play back at all.

To date I have replaced the hard drive with a compatible (I hope) new Western Digital 500 Gb WD5000-LUCT hard drive, and attempted to re-install the software to v1.25.0 as discussed in another thread on this forum - Hitachi PVR, perfect cond H/D won't reformat after re-installation

On attempting to install v1.25.0 via USB stick it generally seems to stop at the 'inst' message on the front panel without further progress, however on one occasion only it progressed through to let me try a first time installation which then froze after completing the channel scan.

Further attempts so far have not gone beyond the 'inst' message as picture below - any help very gratefully received! - thank you.

HDR5T01_'inst' copy.jpg
 

Futaura

Active Member
Do you have HDMI available? It could be an issue with the SCART output. I say that as INST on the front panel means the TV should be displaying the first time INSTallation menu. Does it get that far? FYI, the latest software available for download is v1.29.0.
 

Dzzbob

Novice Member
Thank you for the info Futaura and sorry for the slow reply, unfortunately I still can't get past the frozen INST message with no display on the TV screen. I've tried with HDMI and attempted to install the v1.29.0 software, but no dice.

I'm wondering if it's worth trying a different motherboard if I can find one, or maybe I should just call it a day at this point!
 

Futaura

Active Member
Ok, a few things. The software is held in flash memory - not on the hard drive, so it should not be necessary to reinstall anything. With a new HDD it should say it needs to be formatted, which the software can do. If you already had v1.25.0 installed, the box would never attempt to reinstall it as the version number is the same. And if you can't get past INST, then you won't be able to install v1.29.0 either as you never see the prompt asking you if you want to update.

So, what happened? Have you tried putting the original HDD back in? It could well be that the HDD is fine and the box is not liking the new one for some reason (wouldn't be unusual!). And your original symptoms could be due to a motherboard fault instead.

As neither SCART or HDMI are working, that probably rules out problems there as although it is possible for failures on these, it would be unlikely for both to develop problems. Which means the problem is elsewhere. It is hard to diagnose remotely, but it could be a failure of the flash memory.

I have a tool which will perform a full reflash, but if the flash memory is faulty, it will brick the box. If you have a SCART to RS232 adapter, the debug output from that reports the condition of all the flash memory blocks when reflashing - that way you'd know for sure it is dead.

As you know, the motherboard is the main component of the box - you could replace it, but you might as well find another box of the same model on eBay or something, and swap the HDD instead, if it has content on that you wish to keep.
 

The latest video from AVForums

Oculus Quest 2 VR headset + Rotel A14 MkII Amp Reviews & Best of the Month
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom