Dismiss Notice
Attention AVForums app / Tapatalk users
Sadly GDPR means that, from 25th, we can no longer offer access to AVForums via the branded app or Tapatalk.
Click here for more information.

Hitachi Buzz and 4:3 Display Problem

Discussion in 'Plasma TVs Forum' started by moedeeb, Aug 9, 2004.

  1. moedeeb

    moedeeb
    Active Member

    Joined:
    Aug 9, 2004
    Messages:
    104
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    28
    Location:
    Wetherby
    Ratings:
    +28
    I have had a Hitachi PD 3000 since January. Its been fine up to now but the Buzzing is now getting noticable - (Maybe after reading too much about it on these forums) - Additionally the picture when viewing in 4:3 mode is not in the centre of the screen It's about 2cm scewed to the left. I bought it from Empire and their own service guy is coming round on Wed to have a look. Does anyone have the definitive answer to the Buzzing screen issue. as an ex engineer it seems amazing that Hitachi can produce such an advanced panel but can't select a transformer that doesn't Buzz under different loads.

    Thanks
     
  2. leamspaceman

    leamspaceman
    Distinguished Member

    Joined:
    Jun 22, 2004
    Messages:
    6,981
    Products Owned:
    1
    Products Wanted:
    0
    Trophy Points:
    166
    Ratings:
    +3,037
    Sorry to hear of your problems mate. I would NEVER go anywhere near a Hitachi set again after my brief dalience with them.

    I truly hope you get it sorted. If nothing else, you will find PLENTY of sympathy here.

    Good luck.
     

Share This Page

Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice