1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Hiss from STRDB940

Discussion in 'AV Receivers & Amplifiers' started by jmlane, Jan 25, 2001.

  1. jmlane

    jmlane
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    I have this amp, and have heard problems with hiss on earlier models - how early. Mine seems to be effected witht the problem - at what sort of volumes does it become apparent and is there a fix available to those with the earlier version of the amp?

    Cheers.
     
  2. Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    I have the 930 version and have also noticed hiss from the centre channel at all volumes but obvioulsy it is very noticeable at low levels.

    KC

     
  3. Digikid

    Digikid
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    i have bought recently a 940, and have exprienced a slight hiss, it is only slightly noticable if i put the bass boost on.

    Some have suggested turning the EQ faciltiy off as well, the problem is we shouldn't have to do that!!

    Its not a major problem with mine.
     
  4. tan1415

    tan1415
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Are you sure about this?
    Damn this sound pretty ugly.
    I was thinking of buying it or the 586 from yamaha.
    I don't think tha Yamaha suffers from the same problem.

    Which other Amps did you audition before getting thsi amp?
    Or was because of the reviews about it?
     
  5. jmlane

    jmlane
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    The hissing isn't that serious, and I'm not sure it affects all the amps, get a demo, the reviews say it all, it's a brilliant amp.
     
  6. GidGrace

    GidGrace
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    This problem is not affecting my 940, bought from Letsbuyit.com in December 2000.
    Maybe there's a dodgy batch out there...?

    Gid
     
  7. Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    So, are you telling me that you have already received the Sony STR-DB940 from LetsBuyIt.com.
    I was also a co-buyer for this amp (which ended on 14th December) and still have not received it. They took my money but still have NOT delivered!
    Was this the same co-buy as you? When did you actually get the amp.
     
  8. GidGrace

    GidGrace
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Chauhaaj,
    I joined a co-buy which ended on 30th November 2000 and the amp was delivered 22nd December.

    If you are out of pocket, contact your card issuer who will ask you to fill out a form and then happily refund your money.

    I purchased some other bits from letsbuyit.con around the same time and these still haven't arrived - I'm awaiting £130 refund and 4 cinema tickets - American Express have said they will refund the money if I want, but I am waiting to see what happens...

    Gid
     
  9. Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    turned on the bass boost and found the hissing was more audible,not when this was off.
    martinc

     
  10. tan1415

    tan1415
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Hi Guys,

    Lets buy it.com has been in financial trouble.
    They are on the edge of bankruptcy.


     
  11. dmckillop

    dmckillop
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    I think letsbuyit.com have just been bailed out.
     
  12. tan1415

    tan1415
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Hi ,

    Just bought my machine and to tell you the truth the Hissing is pretty noticeble from my frontspeakers.
    So you should shutout your EQ and Bassboost?
    Damn i am not even using the Bassboost but you can't avoid using teh EQ right?
    If you play a cinema ex a or other dsp modes it automatically uses the EQ.

    Damn it's pretty crappy. I checked all the connections. And i can't believe that the problem is there.


    Hope you can help me out.


    DT
     
  13. GidGrace

    GidGrace
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Some people are sooooo unlucky - they buy a rated amp and it starts hissing at them.
    I have the 940 & mine doesn't hiss noticeably - I use the Cinema EX B mode with bass boost off and haven't messed with the EQ.

    If this fault is so annoying, surely you have cause for a refund or exchange...?

    Gid
     
  14. tan1415

    tan1415
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Yeah just my kind of luck.
    According to a salesperson. Hiss from A/V amps is normal. And that speakers that's pretty sensitive is more likely to let you hear the hiss.The more sensitive the more distortion you'll hear.

    I am not sure what to think about this. But i have a feeling he rather not have me return/exchange the receiver.

    BTW Gid, How did your hookup go? Could you connect your VCR via Svideo thru your amp?
    A friend of mine have done this.
    He connected DVD,LD and VCR thru his amp.
    And used Svideo-scart the amp to the TV.

    And how high do you turn up your amp? With movies i always set the volume between the 9 and 10 o'clock mark.

     

Share This Page

Loading...