1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Help with Toshiba 50wt29b

Discussion in 'Televisions' started by caleb2002, Oct 25, 2002.

  1. caleb2002

    caleb2002
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Please help my RP is acting a little dodgy.

    Only 3 months old and I am finding that lately it was taking ages to power up the screen, now it takes ages and then no picture is received but the menus appear (when pressed) but the colours are way out of sync and for some reason the convergence menu does not appear.

    If I leave the set off for an hour then the picture will appear but the set crashes after a few minutes.

    When I got the display the convergence menu came on so I checked it and it looked fine,

    Any ideas?

    Cheers:confused:
     
  2. caleb2002

    caleb2002
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Nobody had a problem like this?
     
  3. HBK757

    HBK757
    Standard Member

    Joined:
    Jan 15, 2002
    Messages:
    153
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    16
    Ratings:
    +0
    Sounds like a big big problem to me. The convergence board might have died or something, especially if the colours are out of sync so badly. My advice is to call the company you purchased the TV from and tell them its completely unwatchable, hopefully they will notify a Toshiba engineer who will then come out to have a look at it and verify it is in fact buggered. The engineer will either then recommened one of two things - The TV be taken to their repair shop and repaired, or you be given a new TV. I would strongly push for the second option, just tell them you won't be happy with a repaired TV which is only 3 months old and you paid so much for.

    Let us know what happens, best of luck.
     

Share This Page

Loading...