Help with Setup Please?

Discussion in 'AV Receivers & Amplifiers' started by Headspun, Dec 19, 2006.

  1. Headspun

    Headspun
    Standard Member

    Joined:
    Aug 5, 2005
    Messages:
    91
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    8
    Location:
    Dublin
    Ratings:
    +2
    Hi, I have been refurbishing a house and its almost complete. Sky Hi-def being installed as I type. Because of all the dust and boxes etc I have never bothered setting up the equipment properly.
    The sound is no problem (both have 3rd gen Denon link), but could someone please advise the best way to connect and to setup the two Denons, Sky box and the TV. Also are there any upgrades for the Denons?
    I have looked to see if this question has been asked before. I'm sure it has but I can't find it, but dont be afraid to point it out to me
     
  2. MPK

    MPK
    Active Member

    Joined:
    Nov 26, 2004
    Messages:
    478
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Location:
    London
    Ratings:
    +8
    There are upgrades for both the DVD player and amp in order to put through 1080p video. Since you have a 1080p panel that might be worth looking at. However, it means having to ship both units and probably waiting for a looong time...

    Regarding video connections, I would just use HDMI from the DVD to the Amp and to the Screen. Also, of course, from the Sky HD box. There's no better way.
     
  3. Headspun

    Headspun
    Standard Member

    Joined:
    Aug 5, 2005
    Messages:
    91
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    8
    Location:
    Dublin
    Ratings:
    +2
    Thanks MPK.
    i have tried the simple hdmi connections. But the amp is giving me problems. i can read the menu perfectly on screen, so the "video out" is working. But I cannot view either dvd's or sky played through the amp.
    If I connect them directly to the tv, they both play perfectly. so somehow I am not setting up the video input correctly, even though I am following the manual and have tried different hdmi cables etc.
    Any further ideas? It would make my Christmas!
     
  4. MPK

    MPK
    Active Member

    Joined:
    Nov 26, 2004
    Messages:
    478
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Location:
    London
    Ratings:
    +8
    Sorry, didn't have access to internet for a while. Hmm...sounds a bit like what I originally had with my amp: An HDCP issue. The problem with my DVD player was that it had an old firmware which was only HDMI 1.0. However, if you have an amp or repeater inbetween then it needs to be HDMI 1.1. As soon as I upgraded the DVDs firmware it worked. However, this would only explain the DVD player, but not Sky HD. I would be surprised if Sky HD wasn't HDMI 1.1 compatible.

    Other than that I really wouldn't know what it could be, i'm sure you've tried the V.Sel (video select) button, checked the cables, the input settings on the TV etc...?
     

Share This Page

Loading...