Help with setting up Nebula DigiTV Networking

wyerd

Active Member
I'm pulling my hair out trying to get the client/server connection working. I've tried all options but the client can't find the server. The server's IP address is 192.168.1.10 and client is 192.168.1.11 - do I use these address or the default 230.1.1.1??

Thanks,
David.
 

wyerd

Active Member
I've put the client address of 192.168.1.11 in the client box on the server. Ports 2820 & 2821. Multicast unchecked.

I've selected Client on the client side. Multicast unchecked.

I see the didgi icon in the systray go green on the server, but the client then says no server found, and the icon goes red.

I'm using winVNC to connect to the client so comms is OK (& I don't have to run up and down the stairs!)

No network firewall - ICF not enabled on both PC's - Trend Personal Firewall not enabled. The only firewall I have is on the ASDL router/hub which is only on the Internet side, not the LAN side I belive.
 
B

BertG

Guest
Originally posted by wyerd
I'm pulling my hair out trying to get the client/server connection working. I've tried all options but the client can't find the server. The server's IP address is 192.168.1.10 and client is 192.168.1.11 - do I use these address or the default 230.1.1.1??

The networking feature of the current (3.11 build 2) DigiTV software is buggy as hell.

If on the client you keep checking the "is a DigiTV Client" radio button it will keep trying to find the server and if you get lucky it might find it and allow you to watch on the client for a while.

There is a bit of a thread here

http://forums.sudhian.com/messageview.cfm?catid=51&threadid=53154

about networking problems.
 

wyerd

Active Member
Originally posted by BertG
The networking feature of the current (3.11 build 2) DigiTV software is buggy as hell.

Yep, I'm using 3.11 build 2. I'll check out the link.

Cheers.
 

Higgers

Active Member
I'm also having serious problems with the v3.11 drivers. I've got the DigiTV card configured to be a server with the multicast checkbox ticked. The only way I could get two other client PCs on my LAN to see the server using multicasting was by reading the multicasting Howto at www.tldp.org and issuing the following command in a command prompt (I run Win2k on all my PCs):

route add 224.0.0.0 mask 240.0.0.0 a.b.c.d

where a.b.c.d is the ip address of the PC. I had to use the above command on both the server and the clients. I didn't need to make the above route a persistent route that stays on the PC between reboots. It seems that once the clients have found the server they don't need that route anymore.

Anyway, the above is a bit academic because now that the clients can find the server they can't tune into all the available channels. Sometimes they'll find half the channels, sometimes the other half and sometimes none of them! Arrrrrrrgh!!! I'm going to revert to an earlier version of the drivers to see if one of them works.

Anyone know how to get a Nebula card working under linux? :rolleyes: :laugh:
 

Pootle

Standard Member
The channel pick up on the client is currently broken, save the channel info on the PC with the card and load into the client machine when digitv is not running (and not iconised in the system tray either!
[HKEY_LOCAL_MACHINE\SOFTWARE\Nebula\DigiTV\Channels]


It then sort of manages to to find some of the channels sometimes (I'm using broadcast), but the routing thing may need fixed as well, I see my router keeps rejecting packets from the client to 230.0.0.1 (which need to go the the server PC, not the router...)
 

Higgers

Active Member
Has anyone else had to do add a multicast route using this command?

route add 224.0.0.0 mask 240.0.0.0 a.b.c.d

Or am I the only one? I'm just curious to know if my setup is abnormal in some way.

Pootle, I just looked at the multicast HOWTO at www.tldp.org again and it says that any multicast capable device joins the "all-hosts" group (224.0.0.1) at startup which might explain why your router is rejecting packets from the DigiTV server.

The HOWTO also says that pinging 224.0.0.1 returns all hosts in the network that have multicast enabled. I just tried that and all I got were replies from 224.0.0.1. Wierd.
 

rhinoman

Well-known Member
Newb to the nebula but I got this working (eventually).

I use ip's behind my router with the adress range 192.168.0.1 - 192.168.0.100. Iset the multicast address to 192.168.0.255 and voila. you can then connect multiple clients.
 

The latest video from AVForums

Podcast: LG C1 Review, Apple Lossless & Dolby Atmos @ no cost, Sennheiser IE900 review + more
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom