• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

Help with setting up Home network properly

FraGGer224

Standard Member
Hi guys, been reading a lot on here for a little while now but haven't posted much yet. So I thought I'd post about a problem I have.
I am trying to set up a network for my home, not so much to do with sharing stuff from and to devices but so that every wired and wireless gadget has its own I.P. and connects straight away.
Ill start from the beginning.
We are with TalkTalk and got their free router made by
HUAWEI EchoLife HG520b
Now I don't know much about networking my self that's why I need some help setting it up, at the moment we have 2 xbox 360's via wire, 2 laptops(one vista one win.7), 1 android phone(SGSII), 1 iphone(3gs) and 1 android tablet (galaxy 10.1)
is that router even possible to cope with that many things? a few times I would connect one of them and it wouldn't let me connect which meant I would have to reset the router and try again. If it is the router what other router could I get to replace it in order for it to cope.
Also how do i give each one it's own I.P. address?
any help would be much appreciated.

Thanks
Chris

P.S. I am able to access the router trough my laptop
 

LJx

Prominent Member
The router will automatically give everything an IP address using DHCP providing it is switched on. I don't know anything about the router but it certainly should not have any problems handling that amount of device's. Maybe it was playing up, or maybe one of the devices you were trying to connect to it were when you have had problems
 

FraGGer224

Standard Member
it seems to have problems at random times, sometimes 3 devices are on it and another joins and it will just stop and other times it will handle all and just time out, DHCP is enabled but since I've given all the devices a static IP it's been doing it a lot less than when I have them set to AUTO
 

MarkE19

Moderator
Make sure that any static IP address is outside the DHCP range, ie the router is say 192.168.0.254 with say 5 static IP devices from .249 - .253
You should then set the DHCP range from 192.168.0.1 to say .220 so you have room for additional static IP devices to be added. Then if you have any friends connecting their phone etc to your network DHCP wont try to assign the same IP address as one of your devices that has a static address.

Also worth checking how busy the wifi channel your router is using is. If you have a neighbour with a router using the same channel it could be causing interference with your devices. Run a program such as inSSIDer on your laptop to show the least congested channel available.

Mark.
 

The latest video from AVForums

CES 2023 Round Up: New TV Lineups for 2023 from LG, Samsung, Panasonic, Hisense & TCL
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom