1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Help with SACD

Discussion in 'AV Receivers & Amplifiers' started by karkus30, Jul 24, 2004.

  1. karkus30

    karkus30
    Banned

    Joined:
    Jul 29, 2002
    Messages:
    13,991
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    136
    Ratings:
    +1,261
    Having used my venerable Philips 962SA for a couple of years for DVD playback, I thought I might explore its capabilities a bit further as it has SACD. Duly tooled up with 6 interconnects and plug into the 6 channel ext input of my Denon AVC 10. Popped in Pink Floyds DSOTM and pressed play.

    Result, out comes a pretty distorted sound from the right speaker (loud buzzing hiss) the other speakers hiss a bit, the sub doesnt seem to know that anythings happening. You can hear the music, but its like listening to a detuned radio channel.

    Any ideas ? or just a faulty player ? too late to send it back now or is there something Im missing ?
     
  2. vonhosen

    vonhosen
    Active Member

    Joined:
    Jan 6, 2003
    Messages:
    1,835
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    41
    Location:
    London
    Ratings:
    +13
    Not trying to get you to suck eggs but you have pressed the Ext In/Ananlogue Direct button on the front of the amp yes ?
     
  3. karkus30

    karkus30
    Banned

    Joined:
    Jul 29, 2002
    Messages:
    13,991
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    136
    Ratings:
    +1,261
    I have a switch for each 6ch ext, analogue and direct. But the only thing that gets the sound through is the 6 channel external switch :confused: . I do get sound, but its distorted badly, like a de tuned radio. The sub sometimes kicks in, but only after the disc has been playing for 10 minutes or so. :confused:
     
  4. Ian J

    Ian J
    Banned

    Joined:
    Aug 6, 2001
    Messages:
    25,529
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    166
    Ratings:
    +4,906
    If it's any help I also have an AVC10 and Dark Side of The Moon SACD and it sounds great.

    I have a Pioneer 656a and although it is 18 months since I set it up I seem to recall having to match all of the levels within the Pioneer setup menu
     
  5. karkus30

    karkus30
    Banned

    Joined:
    Jul 29, 2002
    Messages:
    13,991
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    136
    Ratings:
    +1,261
    :mad: :mad: so have I and its driving me nuts. Matching levels ? could'nt manage to remember exactly what you did ??

    I tried swapping to SACD o/put in pure stereo, the result was the same. It will play pure CD mode without any hassle.
     
  6. Stereo Steve

    Stereo Steve
    Active Member

    Joined:
    Jul 11, 2003
    Messages:
    1,914
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    38
    Location:
    UK
    Ratings:
    +7
    Sounds like a fault in either player or amp to me, probably player outputs as I've had a number of problems over the years with DVD players outputs going 'quiet'.

    Try plugging the L/R phonos from a known good piece of equipment into the L/R of the 6.1 input on your 10SE and see if you get good clean stereo when you select 6.1.

    Also, now you have the DVD connected up via 5.1's try setting it to output DD/DTS via them and see how that sounds.
     
  7. karkus30

    karkus30
    Banned

    Joined:
    Jul 29, 2002
    Messages:
    13,991
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    136
    Ratings:
    +1,261
    It plays the none SACD signal OK into the L/R of the 6.1 input and also into the CD input on the amp. As soon as it ouputs the SACD signal it misbehaves, its quite obvious its the player :mad:

    I have also noticed that its recently had a few problems playing a DVD right the way through without freezing (I put it down to a faulty disc, but I am not so sure). Maybe its on its way out !
     

Share This Page

Loading...