Help with quest 2 not working with steamVR

Elvis841

Member
I bought my quest 2 black friday and have since had major issues getting it to work with SteamVR whilst using the Airlink feature. I used to own a Rift S, and while I had no issues with it, wanted an upgrade to the wireless VR world.

Using the quest 2 in its wired state I have no issues using SteamVR. Its only when I open up the Airlink feature that the SteamVR mode becomes frozen for me. I launch SteamVR and then I sit in the loading SteamVR world forever. I have attempted to launch games from steam directly by adding it to my oculus library, I have attempted to launch SteamVR, sit in the loading world for a while, and then launch the game independently but nothing.

I have tried to google for a fix but all I have gotten so far is to do the exact same thing I have already done. This seems like a good community to ask about my issue, so please any help is appreciated.
 

KingD

Well-known Member
try and have a look on your desktop when doing this, sometimes the app will have launched minimized and will need to be "maximized" on your headset. Also for some reason I found different apps would sometimes launch better by opening directly on the desktop with the headset off, or browsing into my steam library on the headset and launching from there.
 

rhodos

Well-known Member
Couple of things that might help from my own experiences with OQ2 :-

1. Disable HDR in Windows 10.
This completely knocks OQ2 sideways and you get a very peculiar error message that doesn't point to HDR at all. Perhaps it was me alone, but 'google' agrees and I've had the same error on two different OQ2s.

2. Double check your PC and router are attached at 1Gbit WIRED. I also had an issue where despite having a router in my office with Gbit ports and a PC with a 2.5 Gbit port I had foolishly used a poor quality ethernet lead which meant only a 0.1 Gbit connection, i.e. 100 MBIT. DOH!!! Had me for hours that one. So despite 800Mbit 5Mhz AC wifi with the OQ2 as the only client on the router I was limited by the 100Mbit ethernet lead in the chain.

3. You may not know but the 'menu' button on the left controller brings up Steam VR much as the menu button on the right controller brings up the OQ menu. Again I spent many a confused minute looking at the Steam VR 'hills' world wondering where the true menu with apps/games was. Again google agrees but hard to find. Just hit the menu button on left controller and it pops up.

Perhaps these wont fix your issue, but they were the 3 big issues I had setting up my OQ2 and tbh they were a nightmare to diagnose as no error messages at all pointed to them. Have fun.
 
Last edited:

The latest video from AVForums

Panasonic LZ2000, LZ1500 & LZ980 Hands-on Launch Event | No QD-OLED for 2022, new 77-inch for LZ2000
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom