Help with Orange Livebox & Remote Desktop

paul-av-tech

Active Member
Any help appreciated here!...
The boss has just been swopped to Orange at home, supplied with a Livebox wireless router.

Using a laptop which I am 100% certain is operating correctly. I am able to connect to work using a VPN connection. The remote desktop however fails to operate. it appears to find the PC but gives the error that username password cannot be authenticated.

I know the laptop is OK and the work end is OK, as I can take the laptop to my house and connect to work with no problem.

I have turned off the livebox firewall - no joy, I have tried adding port forwarding rule for port 3389 - no joy.

Has anyone got one of these working in this configuration?!

Tech help seems to be a little poor to say the least with orange!

Only other thing I have not tried is another router as a temporary install to prove its that! Any suggestions would be very helpful thanks
 

devbod

Active Member
Is the laptop running Vista? Vista seems to have networking issues that surface with certain routers. Cripples network traffic and can cause remote desktop sessions to break in the way you describe while leaving other network traffic running slow but at least still functioning.

I had a similar issue with a speedtouch 585 which resolved when I changed the router to a netgear 834.
 

paul-av-tech

Active Member
Thanks for that, the laptop is xp home and its connecting to xp pro. I jnow both the laptop and the workshop machine are configured OK as they work flawlessly at my own house (using a Netgear DG834 router)

The VPN passthrough appears to work with the livebox, just the remote desktop - so I was assuming a port was being throttled. But as yet no joy. Unfortunatley need to retain the livebox for his second phone line option using voip. His orange package allows unlimited free calls to South Africa where his relations are, otherwise would probably not have gone with livebox anyway!

Thanks anyway, all help appreciated!
 

devbod

Active Member
I'd be very surprised if the default router firewall settings were causing a problem with remote desktop. I know remote desktop is very sensitive to network errors, might be worth logging on to the router and checking the network statistics to see if you have a very noisey line.

Only other possibility I can think of is that the firewall at the office end is using the src ip to selectively block traffic. Problem is symptoms arent consistent with a firewall issue as if initial contact is being made then some packets are getting through.

Are the working/nonworking tests the same, going to the same target pc with the same user id & pw?
 

paul-av-tech

Active Member
Hi again, things have moved on - but still no go.

The target PC (XP PRo) is the same in all tests.
The laptop works at my home using madasafish and a Netgear router. The router is dynamically allocating ip address etc. I can also use all of my home pcs with no issue.

I had another go yesterday. With someone at the receiving end looking at the router. It appears that the VPN is up and connected. Yet the remote desktop states unable to connect / authenticate etc. etc.
I also pulled out the livebox and fitted an el-cheapo BT wired router (which I know works with vpn pass-through) with the same results.
I tried turning off windows firewall - same, also disabled the livebox firewall and set the laptop to a DMZ. Still no go!

Orange state that they have not 'nobbled' VPN - but you are on your own. Fair enough, Next step was is to take my own laptop over which I know works too!

Starting to get depressed about this - Boss is OK about it - but I will hate to be the one to tell him I recomended the wrong option for his home :(

Realy appreciate any further help. I will check line stats next time I am over, plus I have copied the settings from my home machine to compare
 

devbod

Active Member
Can you ping the target pc? Havent had much to do wth VPNs but worth checking the ip address range handed out by the livebox isnt using the same subnet as your office.
 

mattclarkie

Distinguished Member
Well when I beta tested the Liveboxes for Wanadoo I got through 5 of them, and in the end told them to shove the beta as I couldn't take anymore.

I still have 2 non-functional boxes clogging up my spare room.

I wouldn't be suprised if it is the Livebox, no idea if they have fixed the issues with them, but they seemed to need a complete redesign.
 

mattclarkie

Distinguished Member
I use VPN via windows Vista connected through a DG834G using a BT HomeHub as the modem, no issues with that.


DG834G FTW


From my knowledge, when it was Wanadoo Broadband many of the ports and services were blocked by the ISP, maybe they prevent VPN working on the Home packages. They used to block practically all email systems.
 

paul-av-tech

Active Member
Cured!! :) Standard settings for livebox are fine for VPN pass through.
The problem was the IP range assigned by the DHCP server. The Receiving router was set to assign 192.168.1.xx and this is the same as the Orange Livebox. My home router was set to 192.168.0.xx and worked fine.

My theory, is that as the receiving remote desktop machines IP address was in the same IP range as the orange routers, the Orange router would only look within its own local internal network - and did not consider any machine down the VPN tunnel to be within the local network. Appreciate anyone cleverer than I to confirm this, or correct my working theory!

I could have altered the livebox to something else, but was concerned the same would happen in the future with someone else. So I ended up using 192.168.11.xx as the local internal range (which caused all in the garden to be rosy) and hope that no router on the market by default uses this range!!

Thanks to all who gave suggestions etc. that at least put me on the right track. Thanks again :smashin:
 
R

robibby

Guest
Hi Paul, on the offchance you may be able to suggest something, I'm unable to connect to work,have amending the DCHN range (under advanced/network) per your above post, but still can't connect through the Livebox; although other colleagues can using the same laptop through public broadband.

All I know is that the broadband provider needs to be able to support VPN and Orange support give very woolly answers about it. Can you advise how I might go about changing the livebox settings? Haven't a clue what I'm doing!
 

paul-av-tech

Active Member
Sorry Robibby - only just spotted your posting! Orange tech support is zero as far as VPN - looks like you found that out already...

Sorry if this is basic stuff, but I was caught out on a 'silly' so its worth checking.

I know you have altered the IP range served up by the livebox, but make sure it is still within the same subnet mask.
At work check the IP range of the PC's - If its 192.168.1.xx onwards I would recommend something such as 192.168.11.xx Alternatively if a colleages router works OK then ask for his DHCP settings and replicate those to the Livebox. As those more cleverer than I pointed out. Once the VPN has been established you can confirm all is well by opening a cmd prompt and pinging the external IP address of the machine you wish to connect to.

Also I am not sure if the latest service packs have changed security settings - but originally I could connect via VPN using the workstation name, now I need to use the IP address.

I found that the livebox would connect without altering the firewall from its default settings - nor did I need to set any IP pass through rules etc.

Please bang back a posting if I can suggest anything else :)
 

The latest video from AVForums

Podcast: Sky Glass, Epson Laser Projectors plus Home Cinema Subwoofers and More…
Subscribe to our YouTube channel

Full fat HDMI teeshirts

Support AVForums with Patreon

Top Bottom