Help with LCD TV/ Monitor

B

ben0l0

Guest
I am using my Cello 15inch LCD TV as a computer monitor in my bedroom. For some reason whenever I right click on anything, the screen goes black for a second ,almost like it is going on standby and then flicks back on again.

Does anyone have any suggestions as to what could be causing this.

Many thanks
 

Sicton

Standard Member
It sounds like a bizarre input device and graphics output glitch.

When did it start occuring? What graphics card do you have? Have you changed any settings such as resolution since it started?
 
B

ben0l0

Guest
Its happened for as long as I can remember. It only happens when I right click to copy or cut an icon not if i right click any other time. Graphics card is GEforce FX 5500 256MB
 
B

ben0l0

Guest
Infact, Ive worked out it only happens when I right click on a Windows Media player video... any ideas?
 

Sicton

Standard Member
You haven't got that ACDSee program installed have you that generates a video preview when you right click? I forget what it's called. That could be causing a switch in refresh rate or something.
 

h8ball

Standard Member
Hi,

This particular problem has been bugging me for weeks on my LG 32LC2DB (32" LCD TV with RGB VGA input). I know this thread is old, but for anyone still suffering this problem, I've found the cause and have a cure for it!

Basically, it's to do with nVidia video drivers. Specifically, it's related to the "Play On My" submenu which appears on the context menu whenever you right-click a video file (AVI, MPEG, or WMV). The nVidia drivers install a "context menu handler" which runs NVCPL.DLL to detect analog display devices and list them in the "Play On My" submenu. It's this detection process that blanks the screen for several seconds!

When you have a monitor as your primary display and a TV as a SECONDARY display, it's nice to have the option Play On My > TV on the context menu. It doesn't matter if the TV blanks out, because your monitor doesn't. However, when the TV IS your primary display and blanks out, the few seconds of seeing nothing but a black screen soon becomes annoying!

Solving the problem is a simple matter of tweaking your Windows registry to disable the links to the "Play On My" context menu handler for AVI, MPEG and WMV file type classes.

To make things easy, I've created one REG file to disable the links and another to re-enable them (if required). Here they are:-

Filename: nVidia-PlayOnMy_Disable.reg
<begin>
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\AVIFile\shellex\ContextMenuHandlers\PlayOnMyTV]
@=""

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\mpegfile\shellex\ContextMenuHandlers\PlayOnMyTV]
@=""

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\WMVFile\shellex\ContextMenuHandlers\PlayOnMyTV]
@=""
<end>

Filename: nVidia-PlayOnMy_Enable.reg
<begin>
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\AVIFile\shellex\ContextMenuHandlers\PlayOnMyTV]
@="{FFB699E0-306A-11d3-8BD1-00104B6F7516}"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\mpegfile\shellex\ContextMenuHandlers\PlayOnMyTV]
@="{FFB699E0-306A-11d3-8BD1-00104B6F7516}"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\WMVFile\shellex\ContextMenuHandlers\PlayOnMyTV]
@="{FFB699E0-306A-11d3-8BD1-00104B6F7516}"
<end>

To save these to your hard drive, run Notepad, cut & paste everything between <begin> and <end> into it and save as the filename given.

To disable the context menu handler, right-click nVidia-PlayOnMy_Disable.reg and select Merge! Hey presto! No more blanking!

To re-enable the context menu handler, right-click nVidia-PlayOnMy_Enable.reg and select Merge. This restores things to the way they were.

Hope this helps.
 

Trending threads

Top Bottom