Help with diagnosing a peculiar issue: HomeHub 5, NAS, MediaServer

BradShort

Active Member
So I have a new HomeHub 5, with a Qnap TS-119 NAS running the built in Twonky media server.

I can see the Twonky server announcing via my Phone and a Tablet, but my other "Hardwired" devices , WDTV, a HUMAX 9200T and a Panasonic BluRay player cannot see the broadcasted media server.

I have also tried other server apps on the Qnap, Plex, Serviio etc but same issue. I have opened up the suggested port for Twonky and still no joy. (although the HH5 is upnp)


Worked fine using my previous Router the Billion BiPac 7800n so am assuming I'm missing something with the HH5?

Any thoughts on how to proceed?

Steve
 

mickevh

Distinguished Member
If you have literally just replaced your router, then it's probable your client devices are still using the IP addresses assigned by the DHCP Server in your old router. If you wait a while, then the problem will probably sort itself out as the IP leases time out and your client devices acquired new ones for your new router (typically this takes 24 hours.) If you cannot wait, try power cycling all your clients and/or force them to so a IP address refresh (if you can - looking at the mix of devices you have, you may not be able to.)

For any devices that you have manually assigned IP addresses to, you'll need to check that they are in the correct address range for your new router and adjust them if required.
 

BradShort

Active Member
Thanks a lot for the reply. It continues to baffle me. Have allowed DHCP to the wdtv and the humax now and they have a got a new IP but still I cannot see the dlna broadcast from the nas on them.

Again, wireless devices are fine. Could it be an issue with the homeplugs and the homehub i wonder . . .
 

PHoSawyer

Novice Member
First thing to check is make sure you can ping from wherever your server is running to your devices, that will prove layer3/4.

Next thing is to definately chuck that Homehub!! I've had the 1/2 & 3 and all were garbage. On all of them I went back to a Netgear ADSL router modem I had from 2006 and it solved all my problems, even the last one I had in 2012! You shouldnt need to put holes in your firewall because the wireless and internal switch is on the same layer 2 network. All in one router/switch/fw goes in the order fw--router--switch/wireless.

Another rant about Homehubs, they seem to constantly drop wireless sessions. This may contribute to your problem. I am really ranting now but not had much exposure apart from a friend in work showing me around the UI, has it a builtin host firewall? make sure theres a hole in this. I know with my HP N54L and CentOs I need to allow the ports/services access.

</rant> =]
 

BradShort

Active Member
Cheers for the response. I , ust admit I'm getting cheesed off with this. It seems as if SMart Setup is to blame so have turned that off. Also, it seems to struggle with fixed IPs.

I want a single plug solution really, ie one dsl/modem/router instead of going back to the modem and 7800n two box solution.
 

mickevh

Distinguished Member
Could it be an issue with the homeplugs and the homehub i wonder . . .

If you remove the HomePLugs and cable directly to the HH, does it solve the problem...?

Increasingly SOHO routers are including their own DNLA server (I've got one that does) so the two might be tripping over each other (or your clients are favouring one and not the other.) If you HomeHub has DLNA and you don't need it, maybe try turning it off (though I don't hold out much hope for that being your issue.)

As PHoSawyer says, firewall rules port numbers etc. should be irrelevant for local devices, the firewall rules etc. in SOHO routers are usually only relevant if you are trying to access local stuff from the Internet. Local to local connections don't pass through the firewall and routing engine in the HH.

Fixed IP's shouldn't be an issue, indeed your HH doesn't even be aware of any statically assigned IP's. However, if you have devices with statically (manually) assigned IP's and you've changed routers and that change effected a change in the internal IP subnet range you are using (and/or the new HH has a different LAN address to your old router) then you need to change any devices with statically assigned IP addressing to reflect this - the HH can't do this for you as it only manages it's own IP and any addressing it's DHCP Server assigns.
 

BradShort

Active Member
I'll check DLNA on the homehub but that would not explain why the wireless devices can find the DLNA servers. I will have to try plugging directly into the router to rule out homeplugs, but I've never had any issue with them and they are usually transparent.

the WD TV and the Humax can still access the net services like NEtflix et al, so I'm not sure its an ip issue. The HH can reserve IP's and none of the devices are set to static, but DHCP, I leave the reserving of IPS to the router.

You are giving me ideas and that is great thanks!
 

next010

Distinguished Member
It could very well be the homeplugs some brands particularly tp-link ones can have UPnP/DLNA problems due to buggy multicast support something DLNA relies on, the BT home hub 5 is also no stranger to UPnP/DLNA quirks.

The only things you can do with the homeplugs are see if any firmware updates were released for them and try moving them to an alternate wall socket, that's it they don't give you control over the guts of the device.
 

The latest video from AVForums

Star Wars Andor, Woman King, more Star Trek 4K, Rings of Power & the latest TV, movies & 4K releases
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom