Help with 4K and HDCP problem

voodoomedoo

Novice Member
Hello all,

New here and have searched extensively without a real solution to my issue.

Recently bought a Benq w2700 and have it connected to a Yamaha rx-v381 receiver which from everything I’ve read passes through 4K and is fully hdcp compliant.

However my firetv cube shows an hdcp2.2 error and tells me it will only stream in 1080p and my Apple TV 4K won’t even let me choose 4K as an option, will only display 1080p

I bought a ‘supposedly’ high speed aoc hdmi cable and still the same issue.

Where am I going wrong. I’m certainly no expert with these things but do I really have to fork out over £100 on an hdmi cable or is there something else I can try

For info, I did access the advanced menu on the Yamaha amp and changed to mode1

Appreciate any responses
 

Dobbyisfree

Well-known Member
Have you tried the two sources directly connected to the projector? (Powering off first).
 

Dobbyisfree

Well-known Member
If that works (even with one of the sources) then you can try each HDMI lead directly connected to test leads.
 

voodoomedoo

Novice Member
We’ll waddya know, plugged directly into projector, everything worked fine. Plugged back into the receiver, boom, everything just worked. You have no idea how many times I’ve unplugged and plugged stuff back in again with no joy but this time for some bizarre reason it worked.

Thanks for you help but it seems to have sorted itself
 

Dobbyisfree

Well-known Member
Did it sort itself out or was it because they plugged in directly first?

We need Mulder and Scully on this one 🤣
 

The latest video from AVForums

AVForums Movies Podcast: Streaming Theatrical Releases And The Future Of Cinema
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom