Help! Sony 5200/HD-E1 Problems

Kev12

Well-known Member
Just got the 5200 on Sat (£700 Hi-Fi Confid), I think its connected correctly, HDMI from E-1 and Sky HD, HDMI out to Pio.
No problem with Sky, 5.1 via optical, its the E1 that I can't seem to get right.
I know it must be the SPDIF/PCM settings in the audio menu but it only seems to output 2 channel to the amp, which is showing Linear PCM 48KHZ on its display. This is on A.F.D. Auto.
Can someone please tell me the right settings for the audio on the E1, or if theres something I've missed on the amp settings?
This has to be the most complicated receiver and manual I've seen!

:lease:
 

Smurkenstein

Active Member
Kev, I dont have either of these pieces of equipment...but I'll try...do you have a raw audio setting on the player? Also, did you try pressing the movie button on the remote? Finally, the amp should briefly flash up what it is decoding...eg dolby digital 2/0 (stereo)or DTS 2/3.1 (5.1 surround)...do you get this and does the blue bar light up ?

AFD auto should automatically pick the right format to decode...you can set it manually, but this shouldnt be necessary.

/edit..what should the title be putting out...true HD?
 

Kev12

Well-known Member
Kev, I dont have either of these pieces of equipment...but I'll try...do you have a raw audio setting on the player? Also, did you try pressing the movie button on the remote? Finally, the amp should briefly flash up what it is decoding...eg dolby digital 2/0 (stereo)or DTS 2/3.1 (5.1 surround)...do you get this and does the blue bar light up ?

AFD auto should automatically pick the right format to decode...you can set it manually, but this shouldnt be necessary.

/edit..what should the title be putting out...true HD?

I thought it would be DD+, or one of the new "HD" sound formats, but all i can get the 5200 to "see" from the player is "Linear PCM/48KHZ".(2 Channel)
Its connected to HDMI 3 with a QED HDMI-P cable, and the SPDIF setting is Bitstream, and the Digital Out HDMI is set to Downmixed PCM.
I know this looks wrong but its the only combination to get the E-1 to output multichannel( according to front panel display).
The blue bar doesn't light up.
The HDMI input menus on the amp don't seem to do anything either, I can't seem to get the option pop up box to appear like you can for the other analogue inputs,
This means you can't assign audio or re-name the input.
Thanks for your input, Smurkenstein, but is there anyone on the forums got this amp/player combination who can help me out?
 

maghed32

Standard Member
Kev, I´m having kind of the same problem. I don´t have the same player as you but I don´t think the problem is connected to the player...
As I understand it from the manual the amp doesn´t recognize the sound through the HDMI input, you have to set it manually. I just noticed this and find it very anoying. I guess we have to feed the amp with sound through a optical cable to be able to use the A.F.D Auto function.
Another problem I have is that the amp goes quite when I choose the DTS sound option on the movie but works on Dolby Digital. Do you have this problem as well?
 

Kev12

Well-known Member
Don't know about DTS, I can't get multichannel anything from the E1!
As i understand it, all thats needed is to get un compressed LPCM audio is an HDMI cable to the receiver.
I've tried every combination of audio output in the player menu, but its still not working. There must be somebody who's lapping up DD+ True HD etc with this player/amp combination, please take a bit of time out to help me sort this.
I'm thinking its the HDMI Input menu on the amp, but I can't fathom it.

Regards Kev
 

Kev12

Well-known Member
Question for anybody who has a Sony 5200 receiver connected to any source that can output LPCM uncompressed audio, (HD-E1, AX-1, PS3, Blue Ray player....)


Q-
Have you got DD+, True HD or whatever, coming out of your speakers?

A yes or no is fine, at least then I'll know its possible.
There seems to be a lot of happy 3200 owners, but I can't recall any 5200 owners saying that they have.


Regards

Kev
 

charliecossie

Active Member
You have said yourself that the player is set to "downmixed PCM".
To me, that means the multichannel signal is downmixed to two channel.
Which is what the amp is telling you ("PCM/48khz/2 channel).
 

kingfats

Distinguished Member
You have said yourself that the player is set to "downmixed PCM".
To me, that means the multichannel signal is downmixed to two channel.
Which is what the amp is telling you ("PCM/48khz/2 channel).

Hi
Agree with above post.Your setting is wrong.should be on AUTO for the HDMI digital out not downmixed PCM.
 

VDG

Active Member
You have said yourself that the player is set to "downmixed PCM".
To me, that means the multichannel signal is downmixed to two channel.
Which is what the amp is telling you ("PCM/48khz/2 channel).

I reckon charliecossie and kingfats are right, you need to set your player to output 'raw' or (L)PCM through HDMI and switch to 5.1/7.1 instead of downmixing the signal..
 

jedifozzie

Well-known Member
on the e1 have the hdmi audio set to auto and dont connect anything by optical just use the hdmi connected for sound and vision. Then when you play hd dvd select which sound format (truehd,dd+ or dts) in the language on dvd menu the display should show pcm,lpcm,mpcm all multi chanel.
 

Kev12

Well-known Member
Thanks for the replys, but I've sorted this out now.
I did have the HDMI audio wrong( though I seemed to try every combination), Its now on PCM.
The thing that cracked it though was a setting in the 5200 HDMI audio menu.
Changing HDMI audio from TV+Amp to just Amp seems to have worked:thumbsup:

Of course there's no mention in the "manual" that this upsets the LPCM multi-channel audio......

(Actually there is, I just read Sonys pigeon English wrong)
 

jayt

Member
Kev12, I have the Sony DA5200es Amp with SkyHD and PS3.

Both connected via HDMI v1.3 monster cable.

Question, when PS3 is connected the blue lamp lights up blue and the surround sound is awesome and forces out to all speakers with seperation.

But.....with SKYHD set on AFD Auto i get no blue light, output in stereo with sub. What should my settings be, do I need to send the sound through optical?????
 

BillBlank

Standard Member
jayt.

For dd from a sky box you need the optical connection. The box has it's own, unusual standard of hdmi that does not output DD.

HTH

Bill
 

jayt

Member
jayt.

For dd from a sky box you need the optical connection. The box has it's own, unusual standard of hdmi that does not output DD.

HTH

Bill

BillBlank, I just did it, connected via optical......set SKYHD options to optical, still no blue light.
 

BillBlank

Standard Member
Sky setup, has an option to output DD over optical, then check your amp is looking at the optical input, on sonys a little "opt" should appear on the display. if not, press the input button on the amp and that should switch it between analog and digital inputs. Last but not least, check your watching a program in DD, not stereo or DS.

If that fails then check the input you plugged your box into on the amp (video1, 2, dvd, SACD etc) has a digital input assigned to it. IIRC on sony's its something like video 1 or 2 and at least the SA-CD input that uses the optical in.

Bill.

Am I the only person on this earth that is anally retentive enough to enjoy reading manuals before I wire it all up? :rotfl:
 

jayt

Member
Sky setup, has an option to output DD over optical, then check your amp is looking at the optical input, on sonys a little "opt" should appear on the display. if not, press the input button on the amp and that should switch it between analog and digital inputs. Last but not least, check your watching a program in DD, not stereo or DS.

If that fails then check the input you plugged your box into on the amp (video1, 2, dvd, SACD etc) has a digital input assigned to it. IIRC on sony's its something like video 1 or 2 and at least the SA-CD input that uses the optical in.

Bill.

Am I the only person on this earth that is anally retentive enough to enjoy reading manuals before I wire it all up? :rotfl:


BillBlank, cheers bud. putting the GUI on, going into input, selecting the very top Input, clicking on options then the rest is up to you.

Nice one, shame its 23:30 and I got work in the morn
 

The latest video from AVForums

Movies Podcast: Star Trek in 4K. Is the new boxset worth it?
Subscribe to our YouTube channel

Full fat HDMI teeshirts

Support AVForums with Patreon

Top Bottom