Help setting up Wake on LAN

Ben

Well-known Member
Hi all,

I'm trying to setup WoL on a Dell XPS 630i running Win 8 Pro (WoW is not needed). I have enabled the following in the BIOS:

- Remote Wake Up
- Auto Power On (Not sure if I need this-?)
- AC Recovery (Set to "Last". Again, not sure if I need this-?)

The following was already enabled in the ethernet power management properties:

- Allow the computer to turn off this device to save power
- Allow this device to wake the computer
- Only allow a magic packet to wake the computer

The following was also already enabled in the NVIDIA Control Panel:

- Wake on Magic Packet
- Wake on pattern match
- WakeOnLAN From PowerOff
- Device sleep on disconnect (Should I disable this?)
- Flow Contol (Disabled by default. Should I enable this?)
- Low Power State Link Speed (Disabled by default. Should I enable this?)

I've also installed & enabled Windows "Simple TCP/IP Services" (not even sure if I need it!)... And now I'm a tad stuck! I've tried a few different free WoL apps on my iPhone4 & none of them have worked, so I'm guessing the problem lies elsewhere. Any ideas?
 

Paul_McG

Active Member
On the device you are using the send the WoL packets, ensure it is configured to send 4 or 5 WoL packets. Some machines will only respond if a few packets are received.
 

Ben

Well-known Member
Assuming this is all connected via a router.

Yeah, sorry, I have a Sagemcom [email protected] router connected to Sky broadband.

I had to do something like this to my D-Link to get WoL working Wake On LAN (WOL) Guide

Thanks for the link. Following that guide, I have:

- Registered & setup a dynamic DNS on my router (Not sure if I needed to, as I'm just trying to use WoL, rather than WoW, but I did it anyway).
- Reserved 192.168.0.3 for the PC in the DHCP server (This is the IP the PC always seems to have anyway. The DHCP server requested the MAC address too, so I entered it).
- Tried forwarding UDP port 9 to both 192.168.0.3 & 192.168.0.127 (I'm unclear as to which of these two I should forward it to, the PC IP or the broadcast IP? My subnet mask is 192.168.0.128).
- Created & enabled an inbound rule in Windows Firewall to allow UDP port 9...

Still no luck. Have I missed something? Are there any tests I can do to see where the fault lies? :(

On the device you are using the send the WoL packets, ensure it is configured to send 4 or 5 WoL packets. Some machines will only respond if a few packets are received.

Thanks. So far I have downloaded Mocha WoL, SimpleWoL & RemoteBoot WoL. SimpleWoL definitely sends at least five packets, as you can adjust the amount from 5-50 (Plus it tells you how many it has sent).
 
Last edited:

Ben

Well-known Member
Well, after a bit of late night tinkering, I've discovered that it was Windows 8 "hybrid shutdown" causing the problem. After going to Control Panel > Hardware and Sound > Power Options > System Settings > Shutdown settings > Turn off fast start-up... It now works like a charm! :suicide:

It also works without enabling any of the stuff I tried in my previous posts, including port-forwarding, reserving IPs, creating firewall exceptions, etc, etc... "Remote Wake Up" doesn't even need to be enabled in the BIOS!

Anyway, I'm a happy bunny, now off to bed. Cheers guys :)
 

The latest video from AVForums

Star Wars Andor, Woman King, more Star Trek 4K, Rings of Power & the latest TV, movies & 4K releases
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom