help setting up 3d for my jvc x7 plz

Alexh22

Standard Member
Hi all

I've finally bought a emitter and 3d glasses for my x7 but I have a problem! The image keeps flickering when 3d is activr. Plz help me sort this out I'm very frustrated.

Thx
 

signs

Banned
Hi all

I've finally bought a emitter and 3d glasses for my x7 but I have a problem! The image keeps flickering when 3d is activr. Plz help me sort this out I'm very frustrated.

Thx
how do you mean "flickering" turning on and off ? losing colour ? :)
 

Alexh22

Standard Member
I mean like the picture is fine then suddenly flashes then normal then 20 seconds later same thing.
 

signs

Banned
Hummm , I'm no expert, but it sounds like a dodgy transmitter to me .

are you local to me ? (staffs) if so you could borrow mine and see how you get on ?
 
Last edited:

Alexh22

Standard Member
it's been flickering even before glasses arrived and also flickers even if the emitter is connected or not
*
 

Alexh22

Standard Member
yeah remove the splitter as i doubt it will be 3D compatible compatible :)
Mate I removed the splitter and still same problen. Can the emitter be faulty? Like I said same thing happens even after remove emitter from jvc.
 

soupdragon

Distinguished Member
I would guess it could be a cable or source issue. Is it a blu-ray player, satellite box, PC etc.....are there output settings on the source that you can change? Eg, sky tv, set it to output 720p or 1080i. Is there an amp in between source and projector.

If you post a more detailed explanation of your complete set up, start to finish it will be easier for someone to spot the issue.

If I went on to a car forum and said "my engine is making a funny noise, can you help?" Thats not really enough detail to go on. I'm not having a dig, just struggling to know what the route of the problem might be.
 

Alexh22

Standard Member
Ok I'm using a xtreamer media steamer. I have a amp which projector connects to also my streamer is also connected to the amp not directly to streamer. I used to have emitter in past and no trouble but this time there is
 

soupdragon

Distinguished Member
Any clues???
When you go into the info part of the menu on projector, what does it say, eg, 1080p 24fp and does this match what the output of your source is. Check if your amp is on hdmi pass through or is it scaling?
 

Alexh22

Standard Member
Both are 1080p 60htz. 24fp is off. Not sure about hdmi pass though I'll check after work but I havent messed with the amp and few months ago I didn't have this problem
 

soupdragon

Distinguished Member
Both are 1080p 60htz. 24fp is off. Not sure about hdmi pass though I'll check after work but I havent messed with the amp and few months ago I didn't have this problem
Is it frame packed 3d as I don't think the projector supports frame packed 3d at 1080p 60hz, only side by side or top bottom. It can accept 1080p 24p frame packed.
 

soupdragon

Distinguished Member
I don't think it's the emitter as it still flickers when the emitter isn't connected. All the emitter does is tell the glasses which lens to open and close and at what time - if the picture flickers without any glasses on then it's something else - not sure though.
Have you tried running the hdmi lead from media player direct to the projector?
 

The latest video from AVForums

The Best Movies and TV Shows Coming to Netflix in November 2020: Tom's Thumbs.

Latest News

Tom's Thumbs: What is coming to Netflix in November 2020
  • By AVForums
  • Published
Melco anniversary edition N10 library announced
  • By Andy Bassett
  • Published
What's new on Disney+ UK for November 2020
  • By Andy Bassett
  • Published
Denon, Marantz and Yamaha AV receivers hit by HDMI 2.1 bug
  • By Andy Bassett
  • Published
McIntosh launches MX100 AV processor and MI347 power amp
  • By Andy Bassett
  • Published
Top Bottom