HELP!!! Samsung PS50Q96 will not turn on!!!

Discussion in 'Samsung TVs Forum' started by Johns23, Jun 13, 2008.

  1. Johns23

    Johns23
    Active Member

    Joined:
    Sep 2, 2006
    Messages:
    155
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Ratings:
    +15
    My sisters samsung ps50q96 just keeps making a clicking noise switching itself on and off constantly with the blue light blinking at the bottom. Its only one week out of warranty but Samsung have said there is nothing they can do now! Is it the psu relay? Any advice welcome.
     
  2. Syphonic

    Syphonic
    Active Member

    Joined:
    Sep 22, 2006
    Messages:
    657
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    28
    Location:
    Scotland
    Ratings:
    +60
    One week out of warranty = Irrelevent. Talk to the retailer you bought it from. Not fit for purpose, Sale of Goods Act. etc. Usual routine.

    Cerainly sounds like a power fault anyway.
     
  3. mcjibba

    mcjibba
    Active Member

    Joined:
    Mar 3, 2007
    Messages:
    367
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    31
    Location:
    London
    Ratings:
    +49
    If you have POP to show it is just a few weeks out of warranty period i am sure they will arrange an engineer visit.


    If you get any problems send me a PM and i will see what i can do to help out.
     
  4. bananaman

    bananaman
    Active Member

    Joined:
    Dec 17, 2002
    Messages:
    380
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Ratings:
    +17
    Hi guys - just to bounce this thread and prove that I did use the search function, *before* asking my question....!!!!
    :D

    My PS50Q96HDX has recently started behaving in the same manner - i.e. making a non-stop clicking sound as if turning itself on and off every few seconds, but there is no picture.... This cycle continues until I unplug the screen. If I plug it back in again immediately, it just keeps clicking :( .....

    I first had the problem a week ago, and went away for a few days. Bizarrely, when I plugged the telly back in when I got home, it all worked fine again - leaving me to suspect it might be an overheat issue, maybe?

    Do you guys have any suggestions as to what may have caused it, and how to resolve it? The TV is over 2 years old - and so is well out of the warranty period and I simply can't afford to replace it... :(

    Cheers all!
    :smashin:
     

Share This Page

Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice