Help Required: PS3 surround Sound issue, details inside

starforsaken

Standard Member
I have a
Yamaha rx659 7.1 amp
PS3 latest firmware
LG 1080p TV
Energy speakers and subwoofer


With my xbox 360 I can get the surround sound and subwoofer to work together. I tested it out with the podracer scene in star wars episode 1 which is quite bassy. The xbox is connected with hdmi to the tv which is connected to the amp- THIS WORKS

My ps3 does NOT work.. I actually got it to play blurays and I can't get the sub to activate unless I turn it onto stereo...

Should I try and optical cable that goes from the PS3 to the amp directly?

thanks
 

davepuma

Distinguished Member
Yes! To get 5.1 you need to connect directly using a digital audio cable from both. At present you're only getting a pseudo effect mixed from the stereo output from the TV. Make sure when you do, that you change the audio settings. The PS3 needs to be set to optical and bitstream.

Edit - You need to connect the Xbox 360 to the amp via optical (Xbox 360 bitstreams DD5.1 over optical) and also the PS3 via optical.
 
Last edited:

starforsaken

Standard Member
Thanks,

I am heading out to get the digital optical cables now!

I really hope I can get it to work... what is the next course of action if it doesn't? sell ps3 and get dedicated bluray?
 

davepuma

Distinguished Member
It will work! The PS3 is a more than capable bluray player. It decodes everything and is updated regularly and doesn't take 3 months to load a disc. Don't spend a fortune on optical cables either. Unfortunately the shops aren't the best for buying cables. Avoid Currys, Comet etc. and go to a proper AV dealers. At least if you pay a few quid, you're getting decent quality cables and not overpriced Monster!
 

davepuma

Distinguished Member
Didn't realise you are in Canada. I'm sure it will be fine. I obviously have no experience of it. If you can get hold of Profigold, they're good value. I think Monoprice and Bluejeanscables are the recommended suppliers over there.
 

starforsaken

Standard Member
PS3 settings/tv/amp settings


So I think I set all the PS3 audio to digital optical and the video to hdmi, but i get no sound

HMM
 

davepuma

Distinguished Member
Ensure it's set to bitstream (it should be by default). Double check your settings. Also I presume you have selected the input you have connected it to (make sure it is assigned correctly too as it may be assigned to a digi-coax connection by default).
 

starforsaken

Standard Member
starting to sound like a broken record...

I got surround sound including sub to work when playing star wars episode 1 through my ps3 dvd, but the dark knight blue ray wont do it?

any ideas?
 

davepuma

Distinguished Member
What are your settings on the PS3?

It should be set to Optical in Sound Settings and then have all the boxes ticked except LPCM 2 Ch 88.2 khz & 176.5 khz (that's what I have and don't have any problems).

Then go to Video Settings (don't ask) go to BD/DVD Audio Output Format (Optical Digital) ensure it is set to bitstream.

Ensure the amp is set to Automatic, so that it decodes whatever is input.
 

starforsaken

Standard Member
The problem was that I didnt know where the bitstream option was, but I found it right after I made my last post.

I dont know about setting my amp to automatic, but I just tested it on 300 blueray and it most definitely is working thunderously. So I assume it is all good>
 

The latest video from AVForums

Podcast: REL T/9x Subwoofer + Bowers & Wilkins PI7 Reviews, AV Shows in a Pandemic and more
Subscribe to our YouTube channel

Full fat HDMI teeshirts

Support AVForums with Patreon

Top Bottom