1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

help! problems with Tannoy 625 ALFie Sub

Discussion in 'Subwoofers' started by clivejones, Sep 19, 2004.

  1. clivejones


    Aug 19, 2004
    Products Owned:
    Products Wanted:
    Trophy Points:
    Hi People...

    Could use some advice

    My sub won't "come on"

    I have a Sony 930AV Amp and a Tannoy ALFie 625 Subwoofer.

    For reasons unknown I have been having a few difficulties.

    There is a red/green light behind the front grill to let you know when the sub is active.

    Its sits on red. Before the problem started when low frequencies started it would switch on and the light would go green. But now the light never goes green.

    There are two control on the back of the sub...
    a little dial to set the frequency filter.... and a button which can be pressed in and out - i believe this is for some form of enhanced mode for music listening....

    Anyway... accidentally one day I spiked the power to the sub from the amp...
    and low and behold the green light lit...
    I had some sub sound for a while... then it dropped...

    obviously i dont wanna spike the power to my sub and/or amp...
    but i repeated this once more ... and the sub came on again...

    Does anyone think that this sub is fix-able?

    Its about 8 years old.... cost about £400

    I cant find any info on the web about this sub....


Share This Page