HELP! Problem flashing Asus Rampage BIOS

PlasmaVirgin

Well-known Member
I have an Asus Rampage III Gene which I must say has been excellent. Today I tried to update the BIOS to the latest version via the ASUS Update software tool which is running on my desktop and somehow I've managed to bugger it up. :mad:

The Asus Updater seemed to be working fine and downloaded the latest version but when I selected to flash the BIOS to the new version it chugged away and then eventually switched itself off. Since then I cannot get the machine to boot up again.

The fans come on and the PC power light illuminates but I'm getting no video signal, etc. PLEASE could someone help!!?? :lease:
 

PlasmaVirgin

Well-known Member
Problem solved! After a couple of nervous hours I finally managed to reflash the BIOS via an Asus startup CD. All now working fine - phew!
 

The latest video from AVForums

Star Wars Andor, Woman King, more Star Trek 4K, Rings of Power & the latest TV, movies & 4K releases
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom