1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Help Power leads mixed up

Discussion in 'AV Receivers & Amplifiers' started by CYRUStheVIRUS, Jan 9, 2005.

  1. CYRUStheVIRUS

    CYRUStheVIRUS
    Active Member

    Joined:
    Jan 25, 2003
    Messages:
    1,304
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    41
    Location:
    Brighton
    Ratings:
    +14
    I have been messing around with my kit and now have 3x 5amp leads and 1x 10 amp lead.
    Servo 15 or my 5 channel sunfire power amp, which one uses the 10amp lead?
    (In the mean time looking for manuals). :suicide:
     
  2. eviljohn2

    eviljohn2
    Well-known Member

    Joined:
    Jul 8, 2002
    Messages:
    7,529
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    86
    Location:
    Near London.
    Ratings:
    +208
    I can't advise you categorically, but my PDR10 and XLS200 have both had 5A fuses and my Marantz SR7400 has a 10A fuse. I would guess that the Sunfire has the 10A lead. :)
     
  3. CYRUStheVIRUS

    CYRUStheVIRUS
    Active Member

    Joined:
    Jan 25, 2003
    Messages:
    1,304
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    41
    Location:
    Brighton
    Ratings:
    +14
    Thanks, i am pretty sure the Arcam dv27 and Tosh sd9500 are both 5 amp.
    Cheers
     
  4. Knightshade

    Knightshade
    Active Member

    Joined:
    Aug 6, 2004
    Messages:
    1,971
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    51
    Ratings:
    +43
    I would think the power amp would have the 10amp fuse. It has the potential to draw the most power.
     

Share This Page

Loading...