Help Please. Panasonic UB820 Won’t Play in 4K HDR ??

Deeez Nuuutz

Distinguished Member
Hi,

Just got a Panasonic UB820 after my Sony S790 stopped working and I’m having trouble getting it to play 4K discs. Trying to watch ‘The Dark Knight’ on 4K and It only plays HD and in the playback settings it’s displaying (1920x1080) SDR/BT.709 ?

Display is an LG C8
AVR is a Denon X7200W


FA37B3CE-FB79-4377-9A95-57AB5A9E96BA.jpeg


Also it won’t display HDR. I have DV and HDR10+set to’On’ in the settings etc. I can’t find the HDR optimiser option anywhere either? Probably cause it’s not playing in HDR??

Nothing happens when I press the ‘HDR Setting’ button either.

These are my settings on the UB820:

242B90E4-1796-4D01-BA52-90E8C777FA94.jpeg

B77744F1-08D2-4E30-855A-82106E9BD758.jpeg
Can someone please help?

Thanks!
 
Last edited:

goingoingong

Distinguished Member
Hi,

Just got a Panasonic UB820 after my Sony S790 stopped working and I’m having trouble getting it to play 4K discs. Trying to watch ‘The Dark Knight’ on 4K and It only plays HD and in the playback settings it’s displaying (1920x1080) SDR/BT.709 ?

Display is an LG C8
AVR is a Denon X7200W


View attachment 1443993

Also it won’t display HDR. I have DV and HDR10+set to’On’ in the settings etc. I can’t find the HDR optimiser option anywhere either? Probably cause it’s not playing in HDR??

Nothing happens when I press the ‘HDR Setting’ button either.

These are my settings on the UB820:

View attachment 1443995
View attachment 1443996Can someone please help?

Thanks!
Top two lines of the playback info display are disc input video and input audio. The last two lines are HDMI port 1 output: video + audio and HDMI port 2 output. video and audio.

The disc you are showing the info for is a 1080p blu-ray. Have you put on the wrong disc and left the UHD in the box?

Have you turned on UHD Deep Colour on the TV HDMI port the player is connected to?
 
Last edited:

Deeez Nuuutz

Distinguished Member
Top two lines of the playback info display are disc input video and input audio. The last two lines are HDMI port 1 output: video + audio and HDMI port 2 output. video and audio.

The disc you are showing the info for is a 1080p blu-ray. Have you put on the wrong disc and left the UHD in the box?

Have you turned on UHD Deep Colour on the TV HDMI port the player is connected to?

I’m soooooo thick sometimes! Must be getting old 🤣

I had the wrong disc in.

Can you tell me how to get the ‘HDR Optimiser’ up please?
 

goingoingong

Distinguished Member
I’m soooooo thick sometimes! Must be getting old 🤣

I had the wrong disc in.

Can you tell me how to get the ‘HDR Optimiser’ up please?
Click options on the remote and then scroll down the pop up menu to picture settings and click OK to select. OR long press on the HDR button on the remote.
 

Deeez Nuuutz

Distinguished Member
You’re a legend! Thanks mate!! 👍
 

The latest video from AVForums

Movies Podcast: Star Trek in 4K. Is the new boxset worth it?
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom